2

Bibliography

Hello, I am using the bibliography and bibliography style packages, but as you can see in the image, Pages and Edition are appearing in English. How do I change to Portuguese?

7
  • Do pleease tell us which bibliography style you employ.
    – Mico
    May 11 at 15:07
  • using in the bibliographic style is plain May 11 at 15:11
  • 1
    page = página ; pages = páginas ; edition = edição May 11 at 16:06
  • 1
    Packages babel or polyglossia usually translate that words. May 11 at 17:12
  • 1
    @SergioLlorente - babel and polyglossia will change sectioning headers such "References". However, they do not modify the innards of the plain bibliography style file.
    – Mico
    May 11 at 17:17
2

First, I would like to recommend that you employ (and modify) the plainnat rather than the plain bib style. plainnat is a re-implementation of the decades-old plain style that has been augmented to recognize field names such as url, isbn, issn, doi, and eid. The plainnat bib style is also capable of producing both authoryear-style and numeric-style citation call-outs; all you need to do is switch between \usepackage[authoryear,round]{natbib} and \usepackage[numbers,square]{natbib}.

Second, here's how you might could go about assuring that the formatted bibliographic entries use Portuguese rather than English words.

  • Find the file plainnat.bst in your TeX distribution. Make a copy of this file and call the copy, say, plainnat-pt.bst.

  • Open the file plainnat-pt.bst in a text editor. The program you use to edit your tex files will do fine.

  • In the bst file, change all 3 instances of " and " to " e ", both instances of "page" to "página", both instances of "pages" to "páginas", and all 4 instances of " edition" to " edição".

  • Save the file plainnat-pt.bst either in the directory that houses your main tex file(s) or in a directory that's searched by BibTeX. If you choose the latter option, be sure to update the filename database of your TeX distribution suitably.

  • In your main tex file, change \bibliographstyle{plain} to \bibliographystyle{plainnat-pt}, be sure to load natbib with the required options, and perform a full recompile cycle: LaTeX, BibTeX, and LaTeX twice more.

Happy BibTeXing!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.