How do I get german umlauts in a PDF using Arial TT-Font and XeLaTeX or luaLaTeX?

The following example produces a box instead of "ü":



You should take a look at the output (log) of XeTeX/LuaTeX:

*** you should *not* be loading the inputenc package
*** XeTeX expects the source to be in UTF8 encoding
*** some features of other encodings may conflict, resulting in poor output.

If you follow that advice, the output of your code is correct.

  • I saw this before and I also tried without but it didn't help. I have ascii not unicode source files. So there is no chance to get umlauts? – AlexG Jun 13 '12 at 11:41
  • 1
    @AlexG you can still use the \"a commands or if you load babel you can use the shorthand "a for ä. With pure ascii, you couldn't key in any umlaut directly (ascii does not define them). You probably have latin1 or any other 8 bit encoding. You can try the package luainputenc although I strongly, strongly, strongly and strongly advice against it. (But then I actually ask myself why you have the utf8 parameter for the inputenc package. – topskip Jun 13 '12 at 11:45
  • 1
    @AlexG luainputenc is really only a last resort. I am not sure if it works in all cases. – topskip Jun 13 '12 at 12:52
  • 1
    Does anything speak against changing the encoding of your source files? – matth Jun 13 '12 at 13:40
  • 2
    Unfortunately, Texniccenter 1 is one of the very few remaining editors that do NOT support UTF8. The upcoming version 2 of TXC will support UTF8. I know some people who use the Alpha 4 productively. In order to make full use of XeLaTeX, you shoud use an editor that supports UTF8. – matth Jun 13 '12 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.