1

I am entering citation information in a table and need an article to use "et al." within the table. However, the journal's style requires longnamesfirst. Is there any way to force et al. for specific cases? I tried \citeauthor*{} as suggested some places (but that's not a natbib command). I also tried \AtNextCitekey{\defcounter{maxnames}{1}} as suggested here

I cannot change the style, or remove the longnamesfirst. I also cannot just manually type in as that wrecks the hyperlinks and automated bibliography.

MWE (although not the correct style file, but it shows the problem)

\documentclass{article}
\usepackage[longnamesfirst]{natbib}

\title{random test document}

\begin{document}
Document with some words and a citation to an article with a lot of authors: \citeauthor{thearticle}.
 
\maketitle

\bibliography{name}
\bibliographystyle{plainnat}
\end{document}

1 Answer 1

2

The natbib citation management package offers the \shortcites macro to list the entry, or entries, which should get a truncated citation call-out even if the longnamesfirst option is in force.

enter image description here

It's best to place the \shortcites directive in the preamble (after loading natbib, of course).

\documentclass{article}

\begin{filecontents}[overwrite]{name.bib}
@misc{abcdef, author = "Aaa and Bbb and Ccc and Ddd and Eee and Fff",
              title = "Thoughts", year = 3001}
\end{filecontents}

\usepackage[authoryear,round,longnamesfirst]{natbib}
\bibliographystyle{plainnat} % or some other suitable bib style
\shortcites{abcdef} % <--- new
\usepackage[colorlinks,allcolors=blue]{hyperref} % optional

\begin{document}
\citeauthor{abcdef}
\bibliography{name}
\end{document}
1
  • @Esme_ -- Please advise whether this answer was useful to you. If it was, please consider upvoting and/or accepting it.
    – Mico
    May 21, 2021 at 4:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .