0

I am trying to install Latex_Suite in MacVim. Before attempting the vim/LaTeX install I downloaded and installed MacTex-2018, the version required for macOS 10.13.6. I then installed and tested TexShop.app and texmaker.app. Both compile LaTeX *.tex files to *.pdf. I also compiled successfully *.tex with pdflatex from the command line. This too works correctly. However, I have not been able to get vim to build *.pdf, \ll does nothing nor is vim even aware that Latex_Suite is installed, i.e., none of the LaTeX commands appear in the MacVim menu system. Here are some relevant files:

which pdflatex
/Library/TeX/texbin/pdflatex

pdflatex -version
pdfTeX 3.14159265-2.6-1.40.19 (TeX Live 2018)

MacVim Custom Version 8.2.2681 (171)

macOS 10.13.6

Can compile *.tex to *.pdf with pdflatex, TexShop.app and texmaker.app.

In vim :scriptnames yields:

  1: /Applications/MacVim.app/Contents/Resources/vim/vimrc
  2: ~/.vimrc
  3: /Applications/MacVim.app/Contents/Resources/vim/runtime/syntax/syntax.vim
  4: /Applications/MacVim.app/Contents/Resources/vim/runtime/syntax/synload.vim
  5: /Applications/MacVim.app/Contents/Resources/vim/runtime/syntax/syncolor.vim
  6: /Applications/MacVim.app/Contents/Resources/vim/runtime/filetype.vim
  7: /Applications/MacVim.app/Contents/Resources/vim/runtime/menu.vim
  8: /Applications/MacVim.app/Contents/Resources/vim/runtime/autoload/paste.vim
  9: /Applications/MacVim.app/Contents/Resources/vim/runtime/scripts.vim
 10: /Applications/MacVim.app/Contents/Resources/vim/runtime/colors/blue.vim
 11: /Applications/MacVim.app/Contents/Resources/vim/runtime/ftplugin.vim
 12: /Applications/MacVim.app/Contents/Resources/vim/runtime/indent.vim
 13: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/getscriptPlugin.vim
 14: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/gzip.vim
 15: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/logiPat.vim
 16: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/manpager.vim
 17: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/matchparen.vim
 18: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/netrwPlugin.vim
 19: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/rrhelper.vim
 20: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/spellfile.vim
 21: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/tarPlugin.vim
 22: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/tohtml.vim
 23: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/vimballPlugin.vim
 24: /Applications/MacVim.app/Contents/Resources/vim/runtime/plugin/zipPlugin.vim
 25: /Applications/MacVim.app/Contents/Resources/vim/gvimrc       

My ~/.vimrc file:

syntax enable
colorscheme blue
set shiftwidth=4
set tabstop=4
set lines=40
set columns=90
set guifont=Menlo:h13
filetype plugin on
filetype indent on
let g:tex_flavor='latex'

Content of ~/.vim

-rw-r--r--   1 carly  staff   150 Jul  8  2018 .netrwhist

drwxr-xr-x  15 carly  staff   510 May 20 14:59 vim-latex-1.10.0

Clearly, I have omitted something or done something wrong. Any suggestions?

Additional info after posting:

I found a reference that directories doc and ftplugin must be children of ~/.vim. They aren't. They are children of the directory ~/.vim/vim-latex-1.10.0, which was created when I did gunzip and tar -xvf on the downloaded tarball. I did this manually from the command line, and perhaps that created an incomplete installation, macOS being particularly perverse about paths. I did not do this sudo. Perhaps I should have. So, I created two symbolic links to make those two directories children of ~/.vim, and surprise, surprise, the Tex special menus appeared in the MacVim menu bar. I can't do \ll for some reason, but I can choose compile from the Tex-Suite menu. When I do that the vim command line displays :silent! call Tex_RunLaTeX()

There do not appear to be any error messages, but there is no *.pdf file in the directory from which the source file was read. So, some progress, but no cigar. Did I shoot myself in the foot by using gunzip and tar to install? Are those two symbolic links sufficient or is there more path and directory management needed? Or should I delete the whole thing and start over?

Solved, pilot error:

When unpacking the downloaded tarball, use a -C ~/.vim directory specification to unpack into ~/.vim. If you download into ~/.vim and then unpack you get an extra directory vim is not designed to search through.

1 Answer 1

0

I solved my own question. Don't download to ~/.vim, but do unpack into ~/.vim. Now MacVim with Tex works as advertised.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .