2

How can I easily disable all ligatures, when converting my LaTex-file to html?

For the html-generation I am using the command-line

mk4ht htlatex file.tex 'xhtml,charset=utf-8' ' -cunihtf -utf8 -cvalidate' '-d./html/'

My latex document begins with the following lines

\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[none]{hyphenat}
\usepackage{microtype}

As suggested in How can I completely suppress ligatures? I tried the following options for microtype: \DisableLigatures[f]{encoding = *, family = * }

The html-output though still contains characters .

2
  • I don't think that hyphenat and microtype make much sense for htlatex.
    – egreg
    Commented Jun 15, 2012 at 14:56
  • @egreg You are right for htlatex but the document is intented for compilation using pdflatex. I only need to create an html once my document is ready. Commented Jun 18, 2012 at 8:22

1 Answer 1

1

Trying several different options led to the following simple solution:

htlatex file.tex

I did not modify my preamble (stated in the question) and did not enable the command \DisableLigatures.

1
  • This does not work for me. Just running htlatex produces file which contains ligature characters instead of separated letters; ligatures are not acceptable for my use case.
    – zstewart
    Commented May 25, 2015 at 3:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .