2

Recently I have installed asymptote in order to try to create some 3d graphics, I have been trying to load a simple hello world program from the cmd and it gives me the error:

pic.addBox(position,position,min(f),max(f));
\AppData\Local\Programs\MiKTeX/asymptote/plain_Label.asy: 321.15: runtime:

I have the latest version of ghostscript installed but for some reason I have not been able to get asymptote to work. Any help for this would be appreaciated greatly.

2
  • I have the same problem. Updated Ghostscript 9.54 to Ghostscript 10.0.0 for Windows (64 bit). Didn't help. Strange, but double click works. Oct 31, 2022 at 8:56
  • "C:\Program Files\Asymptote\asy.bat" %1 This works! Oct 31, 2022 at 11:57

1 Answer 1

2

Ghostscript 9.54 is broken; use Ghostscript 9.53 instead.

Also uninstall the old version of Asymptote you are using and install the latest version of Asymptote (2.70).

2
  • I tried that and it didnt make a difference. the error is still the same
    – xyz04
    May 25, 2021 at 16:01
  • +1: Maybe combine both answers into one. Jan 18, 2022 at 1:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .