0

I'm using the Memoir class, and trying to create a table of contents. I've shopped around on few questions here, and by now I have managed to get all my unnumbered sections/subsections to show up. However, using \tableofcontents seems to create a section or chapter of its own, such that every section in the memoir seems to be a subsection of "contents", like so

 Contents.............................. 1
       Introduction.................... 2
       Dummy Section................... 2
       Dummy Subsection 1.............. 2
       Dummy Subsection 2.............. 2

And so on. Additionally, every paged is now headed with "CONTENTS" in the right page header. Both issues can be seen in the attached picture.

My code is as follows;

\documentclass[a4paper,12pt]{memoir}

\usepackage[utf8x]{inputenc}
\usepackage[hidelinks]{hyperref}
\hypersetup{
    colorlinks=true,
    linkcolor=black,
    filecolor=magenta,
    citecolor=black,
    urlcolor=blue,
}
\title{title}
\author{John Doe}
\begin{document}

\tableofcontents
\setcounter{secnumdepth}{-1}
\section{Abstract}
Blablabla
\pagebreak

\section{Introduction}
Blablabla

\section{Dummy Section}
Blablabla


\subsection{First Dummy Subsection}
BlablablaBlablablaBlablabla


\subsection{Second Dummy Subsection}
BlablablaBlablablaBlablablaBlablabla


\section{Results}
BlablablaBlablabla

\end{document}

Sections being delegated to subsections of 'Contents'

5
  • Use tableofcontents* to remove it from the contents list.
    – Alan Munn
    May 25 at 19:15
  • This removes it from the contents list, but it remains as a page header throughout the document. May 25 at 19:36
  • 1
    memoir isn't really designed to be used without \chapters. There is an article class option which makes \chapter into the equivalent of \section. This should probably solve your problem, but if you're writing an article there are better classes to consider I think.
    – Alan Munn
    May 25 at 19:40
  • Yes, I was using a template (provided by my educational institute) which used the memoir class. I've since resorted to simply using <Report> which works excellently. May 26 at 8:02
  • memoir also covers the report class. If in your MWE you just change {memoir} to {report} then you will get the problem you reported. You must have done something more than that which could be applied to your memoir document. May 26 at 17:44
1

The memoir class is designed as a replacement for the book class, not as a general purpose document class. Because of this, it is designed on the model that the document will have \chapter divisions. This is the source of the problem you are seeing: the \tableofcontents creates an unnumbered \chapter and since you have no \chapter commands in the rest of the document, all of your \section commands are interpreted as part of that chapter.

The memoir class has an [article] document class option which makes \chapter behave like \section, which would probably solve your immediate problem (you would then make all your \section commands \chapter but they would not begin a new page).

Alternatively, if you're writing a document that isn't designed to have \chapter divisions then use a more appropriate document class such as article.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.