0

I'm using this template in APA style: https://www.overleaf.com/latex/templates/template-and-sample-for-authoring-apa7-manuscripts/pvhtwcrvcmsp

The template puts all figures at the end of the document. I'd rather have them where I declare them but I don't really know where I would even look for this. I checked the imported packages but I think you have to change this somewhere else. Where can I adjust this?

2
  • 1
    Welcome to TeX.SX! Probably adding floatsintext to the documentclass options helps.
    – leandriis
    Jun 3 '21 at 16:45
  • Thanks, that indeed solved it!
    – beld
    Jun 3 '21 at 16:52
1

The template you linked to uses the apa7 documentclass in combination with the man option.

In section "8 Dependencies" of the apa7 manual we can find the following:

endfloat: handles placing tables and figures at the end of a manuscript; used only with the man and stu options

which is the reason for the behaviour you observe.

Taking a look at section "4.1 Class options" of the apa7 manual we can find

floatsintext: In man and stu mode, integrates floats (tables and figures) within the body of the text instead of postponing them until after the reference list.

Thus using \documentclass[man, floatsintext]{apa7} should result in the expected figure and table placement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.