I just updated TeXstudio from 3.0.4 to 3.1.2, and uninstalled all the previous versions.
But now, when I try to compile my already saved files on this new version, I get the following error:

latexmk.exe: The script engine could not be found. latexmk.exe: Data: scriptEngine="perl.exe", scriptName="latexmk"

The internal PDF viewer shows the previous version of my file, complied. But it doesn't update to any changes I make to the code, and shows the above error.

Note that I already have MikTeX 2.9 installed.

  • 2
    Is latexmk even installed by default in miktex? Have you tried plain pdflatex instead?
    – daleif
    Jun 3, 2021 at 19:16
  • Sorry, I have no idea about that. What do you mean that I switch to pdflatex?
    – Atom
    Jun 4, 2021 at 1:58
  • Yes, just to see if it makes a difference
    – daleif
    Jun 4, 2021 at 5:24
  • @daleif Oh, I see what you mean now. I had to switch to pdflatex in Configure TeXstudio. And it worked!
    – Atom
    Jun 4, 2021 at 5:36
  • 1
    I use texlive and I use latexmk all the time, it is also the tool that drives overleaf. On Windows texlive comes with its own perl interpreter (latexmk is written in perl). AFAIR miktex does not inklude perl, so you'll have to install perl separately if you want to use latexmk with miktex
    – daleif
    Jun 4, 2021 at 5:39


You must log in to answer this question.

Browse other questions tagged .