15

I just upgraded to Fedora 17 and tried to install TeX Live, as usually, by downloading the install script, install-tl from tug.org. When I run

./install-tl

I get this output:

[giorgos@desktopCosmos install-tl-20120511]$ ./install-tl

Can't locate loadable object for module Digest::MD5 in @INC
(@INC contains: ./tlpkg /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at tlpkg/TeXLive/TLUtils.pm line 198
Compilation failed in require at tlpkg/TeXLive/TLUtils.pm line 198.
BEGIN failed--compilation aborted at tlpkg/TeXLive/TLUtils.pm line 198.
Compilation failed in require at ./install-tl line 53.
BEGIN failed--compilation aborted at ./install-tl line 53.

MD5.pm, however is already installed i.e. when I run

[giorgos@desktopCosmos install-tl-20120511]$ perl -MCPAN -e 'install Digest::MD5'

Going to read '/home/giorgos/.cpan/Metadata'
  Database was generated on Thu, 14 Jun 2012 00:27:03 GMT
Digest::MD5 is up to date (2.52).

Also, I tried to copy MD5.pm to @INC' s path and still I get the same result.

The problem persists in Fedora 20 as well.

5 Answers 5

18

You need the package perl-Digest-MD5

sudo yum install perl-Digest-MD5

After a Fedora 20 default installation, I also found that I needed wget

sudo yum install wget

Now you can install

sudo ./install-tl
1
  • Thanks for this. It works. At home, on my own CentOS build, I have not needed to add anything. At work, it seems they installed an old image disk on my comp where this perl library was missing. Cheers!
    – Celdor
    May 9, 2017 at 9:08
3

The approach described here appears promising.

It goes as follows (for Fedora 17):

# rpm -i http://jnovy.fedorapeople.org/texlive/2012/packages.fc17/texlive-release.noarch.rpm

The package contains repo file for yum which contains TeX Live with binaries. After installing the release package do:

# yum clean all
# yum install texlive

if you don't have texlive already installed. Otherwise you can update your old TeX Live 2007 installation like:

# yum clean all
# yum update
1
  • 1
    That is what I always do and it works very well. Also you can install all of TeXLive by doing yum install texlive-scheme-full, it takes a couple of hours, but you have everything. It saves you the headache of doing the manual installation, the drawback is that you need to be Administrator (or at least sudo-yum user).
    – alfC
    Oct 1, 2012 at 20:42
2

I installed Tex Live on Fedora 17 today and I didn't encountered any problems.

I called the installer like this:

$ perl install-tl

Also I didn't need to install any extra perl packages and I don't any have perl packages installed via CPAN. I used just the perl like it is installed with a default Fedora installation.

Perhaps you are using a local perl installation under /usr/local and/or your CPAN state is messed up. Or your upgrade left out some important perl packages.

2
  • thank you for your answer, even after a fresh install of fedora 17 I had the same problem. Anyway, I managed to overcome the problem after all but I really don't know how I did it; a bit of luck and careful reading of the error messages... anyway, problem solved
    – gstat
    Jun 16, 2012 at 6:51
  • you surely had perl-Digest-MD5 installed has a dependency from another package, the solution is to install it as Nate Iverson suggested Aug 9, 2012 at 11:39
1

I ran into this problem as well, and managed to get the installer to start if I first installed Digest::MD5 via cpan and then ran perl install-tl.

However, I had to run those as root, because otherwise the install script wouldn't let me install TL to the hard drive (because of obvious permissions problems).

This is what I did to make it work:

sudo cpan install Digest::MD5
sudo perl ./install-tl
1

Either install the TeX system that comes with the distribution, or install Jindrich Novy's texlive repository for a newer version. Note that Fedora 18 has the above already integrated, so perhaps a better solution is to just upgrade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.