3

I've been using LaTeX and TeXstuido 3.1.2 for quite a while but always for English text. For English, my spellchecking etc. works fine, but I just can't figure out how to get German spellchecking to work. I'm looking for a simple, German-specific solution (similar to what's available for Italian).

I checked TeXstudio > Options > Configure > Spellcheck. There's an option "standard language", which is currently set to US English: enter image description here The dropdown menu allows selecting other English variants but not German.

I've tried following this answer to download a German dictionary for OpenOffice/LibreOffice. The search function is horrible, there are multiple German dictionaries that I found (not sure which one to select?). I downloaded the .oxt file and clicked "Import dictionary" in the TexStuio options, which always gives me a warning that the file does not include a "Hunspell"-dictionary: enter image description here When selecting, "Yes", ie, still import, nothing happens. There's still no option to select German as default language for spell checking and it's still not checked...

I spent way too much time googling and trying different approaches already. Can't believe how difficult this is... If someone has a simple and specific solution, that would be really great!

9
  • 1
    Try downloading the de_DE (or AT or CH) files from github.com/texstudio-org/texstudio/tree/master/utilities/… (most importantly .dic and .aff) and put them in C:\Program Files (x86)\TeXstudio\dictionaries (or wherever you've installed TeXstudio). After a restart of TeXstudio you should see the dictionary language in the options.
    – doncherry
    Commented Jun 7, 2021 at 19:16
  • It turns out that the de_DE files (eg, .dic and .aff) are already in that directory! But still, German doesn't show as default language option in Configure > Spell Checking. Or am I looking at the wrong place? Or should I simply replace them? Commented Jun 7, 2021 at 19:30
  • 1
    Just guessing here, but try changing the dictionary path in the settings to only the specific directory where your files are. Or (with the program closed) remove (cut and paste somewhere else) the en_US files and see what happens – does TeXstudio still list the dictionary? Try a totally different language (installing the Breton dictionary the way I described worked for me).
    – doncherry
    Commented Jun 7, 2021 at 19:45
  • 1
    Glad to hear it works! It seems [txs-settings-dir]/dictionaries doesn't work here. If I put just that in, my Breton dictionary disappears. So just use C:/Program Files (x86)/TeXstudio/dictionaries instead and you should be able to keep your dictionaries in program files. That does seem to be the current place for them: These dictionary files are recent (2020), whereas those at AppData are a lot older (2013–15) in my case.
    – doncherry
    Commented Jun 7, 2021 at 20:09
  • 1
    Perfect, thanks. That resolves my last questions and my problem :) Commented Jun 7, 2021 at 20:12

1 Answer 1

3

Change the dictionaries path (Wörterbuch-Verzeichnisse) to C:/Program Files (x86)/TeXstudio/dictionaries. The dictionary files of the language you want might already be there. If not, you can also get them from https://github.com/texstudio-org/texstudio/tree/master/utilities/dictionaries (download all files for the language you want).

More info on dictionaries in the TeXstudio user manual, section 1.4.1 Configuring the spell checker.

1
  • 1
    May I add that for users whose TeXstudio is in Program Files (i.e. the 64 bit folder) rather than Program Files (x86) (the 32 bit folder), it works the same except with the other folder: C:/Program Files/TeXstudio/dictionaries. If in doubt, check the folders for the dictionary folder and then use the appropriate one.
    – Markus G.
    Commented Jun 10, 2021 at 10:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .