6

Does anybody know how or if one can use siunitx V3 on Overleaf? It seems that Overleaf only has TeX Live 2020 which does not include the newest siunitx.

Is there any way of getting around that?

1
  • 2
    Not sure, I do think they have tl21, but as far as I know they don't update packages
    – daleif
    Jun 8, 2021 at 19:23

1 Answer 1

4

Overleaf only update after extensive testing. As such, as for any newer package, you'll need to add the file(s) to your project: in this case, you need a copy of (v3) siunitx.sty, which you can get if you have an up-to-date local install or from the 'ready to install' zip on CTAN.

4
  • Would v3 work with TL2020 binaries, expl3 etc.?
    – yo'
    Jun 8, 2021 at 20:56
  • 1
    @yo' Yes, of course: minimal expl3: 2018-06-01
    – Joseph Wright
    Jun 8, 2021 at 21:29
  • Ok great, thanks!
    – yo'
    Jun 8, 2021 at 21:39
  • @yo' Essentially, siunitx uses only long-standing expl3 ideas - the reason for the current version requirement is renames in expl3 not new features. The one thing tht will impact there is when we (finally) have code-level interfaces for \hfil and \kern, but that's sill 'some way off'.
    – Joseph Wright
    Jun 9, 2021 at 6:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .