2

Both ETbb.sty and tufte-common.def require textcomp: The former: \RequirePackage[full]{textcomp}, the latter: \RequirePackage{textcomp}. The option full causes an error message.

Should I remove the option from ETbb.sty or add it to tufte-common.def? Or something else?

% MWE
\documentclass{tufte-book}
\usepackage{ETbb}

\begin{document}
A
\end{document}

Thanks

1 Answer 1

3

Nowadays, loading textcomp should be no longer required. Anyway, you can fix the issue by passing the full option also when the tufte-book class is loaded.

\PassOptionsToPackage{full}{textcomp}
\documentclass{tufte-book}
\usepackage{ETbb}

\begin{document}
A
\end{document}
1
  • 1
    Thank you. Also it is great to know the existence of \PassOptionsToPackage: it is not necessary to edit .sty and .def. files!
    – otaviolb
    Jun 9, 2021 at 23:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .