0

I am not sure how to explain my question that in the title, so I will provide a picture, below. I want that the compiled pdf, when run on pdf readers will have the behaviour of Table of Contents, but my problems are:

  1. Its just doesn't happen on my files, and even when I add ToC (And I want this behaviour even without ToC)
  2. I was thinking that the problem may be because I used unnumbered sections, but it doesn't happen even with numbered sections

my settings are:

  1. Working mainly with Lyx

  2. doc class is Koma-scriptArticle

  3. using mostly Unnoumbered Parts, Sections, etc. enter image description here

  • EDIT: Im adding 2 minimal example files, english and hebrew. In both of them I dont get the required behaviour here

  • FINAL EDIT: So far, I have discovered those things:

  1. It's recommended to have LyX take care of it by going to Document > Settings > PDF Properties and checking the box "Use Hyperref Support" (credit is for @scottkosty)
  2. It is working even for hebrew! For that you need to remove the 'culmus' package (Im not sure how is hebrew working for me without this package, maybe it is because I downloaded some CTM fonts)
  3. To achieve this behaviour even for unnumbered parts, sections, etc one can 'get' this result by adjusting the 'Numbering&Toc' in 'Document Settings' (The meaning is that you use numbered sections, but the number won't appear)
18
  • 5
    You need the hyperref package for such bookmarks. Jun 9, 2021 at 6:58
  • 2
    by default theorems are not in the bookmarks. It would be probably possible to do it, but you would have to provide a complete, minimal example for standard latex that can be used for tests and find out yourself how to convert it into a lyx answer. Jun 9, 2021 at 12:45
  • 1
    Instead of adding the package loading to preamble, it's recommended to have LyX take care of it by going to Document > Settings > PDF Properties and checking the box "Use Hyperref Support". You can add additional custom options there.
    – scottkosty
    Jun 9, 2021 at 15:31
  • 1
    Do you use \chapter* or \addchap for unnumbered chapters?
    – TeXnician
    Jun 9, 2021 at 21:28
  • 1
    @e.ad I suggest you follow the page here to create a minimal example .lyx file and minimal example .tex file and paste them into your question: wiki.lyx.org/FAQ/MinimalExample
    – scottkosty
    Jun 10, 2021 at 15:02

1 Answer 1

1

After removing culmus and your included math macros file, the bookmarks show up for me. This suggests the problem might be coming from using culmus or from the included math macros file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .