0

I am rather new to Latex and I am using it to build my Resume. I encountered two problems: the first one concerns the dates that overflow in the margins, while the second one is I think an embedded comma after the Master that I don't know how to remove. Do you have any idea how can I fix these two problems? Code :

\documentclass[11pt,a4paper,sans]{moderncv}        
% modern themes
\moderncvstyle{banking}                            
% character encoding
\usepackage[utf8]{inputenc}                       

% adjust the page margins
\usepackage[scale=0.94]{geometry}
\usepackage{import}
% personal data
\name{John Doe}{}
\phone[mobile]{123456789}                   
\email{whatever@gmail.com}                               

\begin{document}
\makecvtitle
\section{Education}

\vspace{0pt}

\begin{itemize}
\setlength\itemsep{3pt}

\item{\cventry{}{Master in Whatever}{Random University | \normalfont Random place}{\normalfont 09/2021 - 03/2023}{\textit{}}{}}
\textbf{Coursework:} Random Courses
 
\vspace{4pt}
\end{itemize}
\end{document}
4
  • Well, the alignment issue is simply caused by your using itemize on a cventry. The itemize environment indents all of its entries, shifting everything to the right. It is also not needed for a \cventry as they are already opitmized for the respective layouts you choose.
    – Markus G.
    Jun 10 at 11:00
  • And the comma disappears, if you use the proper {}s of the \cventry, like so: \cventry{}{Master in Whatever}{Random University | \normalfont Random place}{\normalfont 09/2021 - 03/2023}{}{\textbf{Coursework:} Random Courses} In your case the \textit{} command causes the comma, because the {} is not empty and non-empty braces are treated as text, hence the comma.
    – Markus G.
    Jun 10 at 11:04
  • 1
    For the part using itemize please see my answer here: tex.stackexchange.com/a/392894/16550
    – Mensch
    Jun 10 at 11:38
  • Thanks a lot for the help !
    – Ema43
    Jun 10 at 14:53
0

I realised I should combine all of the comments to a proper answer. So here is my approach to your issue. Do note a few things: 1) itemize causes an indent, so be careful when using it whereever alignment is an issue. 2) Using scale as option to geometry is something I do not recommend, I'd rather use actual margins. 3) If you want to add your courses as a list, you can use minipages to do this, I added a small example. Remember to leave the empy line though, otherwise the next entry will be messed up.

\documentclass[11pt,a4paper,sans]{moderncv}        
% modern themes
\moderncvstyle{banking}                            
% character encoding
\usepackage[utf8]{inputenc}                       

% adjust the page margins
\usepackage[margin=1cm]{geometry}
\usepackage{import}
% personal data
\name{John Doe}{}
\phone[mobile]{123456789}                   
\email{whatever@gmail.com}                               

\begin{document}
    \makecvtitle
    \section{Education}
        \cventry{}{Master in Whatever}{Random University | \normalfont Random place}{\normalfont 09/2021 - 03/2023}{}{\textbf{Coursework:} Random Courses}
        \cventry{}{Master in Whatever}{Random University | \normalfont Random place}{\normalfont 09/2021 - 03/2023}{}{}
        \begin{minipage}[t]{2cm}
            \textbf{\small Coursework:} 
        \end{minipage}
        \begin{minipage}[t]{8cm}
            \begin{itemize}\small
                \item Random courses
                \item More courses
            \end{itemize}
        \end{minipage}% leave one line empty after this command
    
        \cventry{}{Master in Whatever}{Random University | \normalfont Random place}{\normalfont 09/2021 - 03/2023}{}{\textbf{Coursework:} Random Courses}
\end{document}

Not the answer you're looking for? Browse other questions tagged or ask your own question.