6

First of all: This is my first attempt using to the KOMA-classes.

It seems to me that the binding correction is not taken into account in what I am trying right now. If I understand typearea right, the following example should have a very tight outer margin.

\documentclass[10pt,twoside]{scrreprt}

\KOMAoptions{BCOR=5cm,paper=18cm:19cm,pagesize}
\areaset{12cm}{16cm}

\usepackage{lipsum}

\recalctypearea

\begin{document}
  \lipsum[1-10]
\end{document}

However, this looks exactly the same as when I remove the BCOR.

How do I get my PDF to be the size of the paper on which the text should be printed (so with BCOR included)? I don't mind that on-screen the inner margins will look out of proportion.

7

It works if you apply the BCOR option after \areaset.

\documentclass[10pt,twoside]{scrreprt}

\areaset{12cm}{16cm}
\KOMAoptions{BCOR=5cm,paper=18cm:19cm,pagesize}

\usepackage{lipsum}

\recalctypearea

\begin{document}
  \lipsum[1-10]
\end{document}
3

\areaset has an optional argument to handle BCOR.

\documentclass[10pt,twoside,
  paper=18cm:19cm,pagesize
  ]{scrreprt}

\areaset[5cm]{12cm}{16cm}

\usepackage{lipsum}
\begin{document}
  \lipsum[1-10]
\end{document}

If BCOR is already set you can use the symbolic value current:

\documentclass[10pt,twoside,
  BCOR=5cm,paper=18cm:19cm,pagesize
  ]{scrreprt}

\areaset[current]{12cm}{16cm}

\usepackage{lipsum}
\begin{document}
  \lipsum[1-10]
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.