1

I'm writing a Portuguese LaTeX file using LyX but for some reason everything is in English. I mean the texts saying "abstract", "figure", and the likes, being in English rather than Portuguese. I already changed the LyX preferences for the UI to be Portuguese, but anything LyX writes such as described above is in English. Does anyone have a workaround for this problem?

2
  • Olá Guilherme! Welcome to tex.se. Great first question! I appreciate that you gave examples of "abstract" and "figure" so it was extra clear what you were talking about. I also appreciate that you described what you already tried (in Preferences). I look forward to your future questions. By the way, if you want more LyX in your life (most do not!), you might consider joining the mailing list lyx-users. It is a friendly and low-traffic list. Also note that one of LyX's core developers is a Portuguese speaker and is on the list, although that doesn't really matter in practical terms :)
    – scottkosty
    Jun 13, 2021 at 16:22
  • 1
    Hello! Thank you, I often see people in these forums making vague questions and they have to spend a lot of replies clarifying what they mean, so it was nice seeing I was clear enough for you XD I might actually join the mailing list, as I really like this software. Always love seeing some Portuguese speakers representation :P Jun 16, 2021 at 14:53

1 Answer 1

0

Go to Document > Settings > Language and change it from "English" to "Portuguese" or "Portuguese (Brazil)". Click "OK". When I do this I see "Abstract" immediately change to "Resumo" in the LyX display and also when I compile to PDF.

More details:

  • If you would like to make this the default for your future .lyx files, you could consider clicking the button "Save as Document Defaults" in Document > Settings.

  • The reason why setting the language in Preferences does not affect the document itself is that there are many users who prefer a different language for LyX but need to write documents in English (or other languages), so the two settings are different.

2
  • I apologize for the late reply, but I could only go back to this now. However, thank you for the answer! Changing this in the document settings worked. Jun 16, 2021 at 14:52
  • @GuilhermeFerrão Great! Thanks for posting back that it worked!
    – scottkosty
    Jun 16, 2021 at 20:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .