I tried to look for similar question, but none of them seems to have the same issue. I'm using the glossaries package and I followed the tutorials on how to use it (see code). The only different thing is that I want to print the glossary after the table of contents page and not a the very end of the document.

% header.tex



% Abkuerzungsverzeichnis
\newglossaryentry{DSL}{name={DSL},description={Domain-Specific Language}}
\newglossaryentry{Bbb}{name={BBB},description={Second abbreviation}}
\newglossaryentry{Ccc}{name={CCC},description={Third abbreviation}}

% Theorem-Umgebungen

% Korrekte Darstellung der Umlaute

% main.tex

% Glossary
\printglossary[title=Special Terms, toctitle=List of terms]
% Chapters
\setlength{\parskip}{1em plus0.1em minus0.1em}

% Appendix
% list of figures
\addcontentsline{toc}{chapter}{List of Figures}
% list of algorithms
\addcontentsline{toc}{chapter}{List of Algorithms}
% Literaturverzeichnis
% Erklaerung

the glossary won't show up unless it is placed right before \end{document}, can I fix it, so that it'll show up? Thanks for any help!

  • 1
    Here is a more minimal code that still produces the issue: \documentclass{book} \usepackage{glossaries} \makeglossaries \newglossaryentry{DSL}{name={DSL},description={Domain-Specific Language}} \begin{document} \printglossary \gls{DSL} \appendix \cleardoublepage \end{document}.
    – leandriis
    Jul 3, 2021 at 8:19

1 Answer 1


The solution that worked for me was to change \include{header} to \input{header} as suggested here. After that minimal change I ran pdflatex main.tex, which finally added the line \@istfilename{main.ist} into my main.aux file. This line was missing previously and the cmd makeglossaries main was giving me an error with the message No \@istfilename found in 'main.aux'. Then I ran latter cmd again.. et voilà!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.