1

I've recently begun exploring Sublime Text + Skim combination for my LaTeX stuff and I've been loving it so far. However, the forward and inverse search seems to be broken. I've tried looking around for solutions but none have been of any help.

For forward search, the user preference setting in the LaTeXTools forward_sync is set to True and using cmd+B to build it shows Running /Library/TeX/texbin/pdflatex /Users/xxx.tex on the Sublime console. Using cmd-l,j outputs Running "/Applications/Skim.app/Contents/SharedSupport/displayline -r -g 195 /Users/xxx.pdf /Users/xxx.tex" where xxx replaces the file path. In both cases, Skim updates the file with the changes, but it doesn't go to my current cursor position in the PDF. I've also tried disabling Skim auto-reload as suggested here, but to no avail.
Possibly related note: On builing the document using cmd+B, Skim doesn't automatically open the PDF; I'll either have to manually open the PDF or use cmd+l,j. However, once the PDF is opened, I have no problems other than getting forward and inverse sync to work.

On the other hand, I have no clue how to get inverse search running. cmd+shift+click on the PDF does absolutely nothing.

I'm on OSX 10.12.5 (Sierra) and using Sublime Text build 4107 and Skim version 1.6.4 (134). My Skim sync preferences for PDF-TeX sync support is set to the Sublime Text preset (and the command and argument fields are greyed out). Any help will be appreciated. Thanks in advance.

1 Answer 1

1

Alright, just figured it out. I needed to explicitly include \synctex=1 in the preamble.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .