0

I am trying to use the LaTeX article document class to create a simple paper with the authors listed on the title page with their (potentially multiple repeating) affiliations as numeric footnotes and other author comments (e.g., corresponding author) as symbolic footnotes. For example, I want something like

enter image description here

However, I haven't been able to make this happen despite trying multiple different solutions. Is there a simple way to do this?

I have tried using the bigfoot package to create multiple different types of footnotes combined with footmisc with the multiple option to get multiple footnote markers with commas between them, but I end up with superposed markers and no footnotes. My minimal latex document is:

\documentclass{article}

\title{My title}

\usepackage[multiple]{footmisc}
\usepackage{bigfoot}

\DeclareNewFootnote{AAffil}[arabic]
\DeclareNewFootnote{ANote}[fnsymbol]

\author{
        David Kaplan\footnoteAAffil{A University}\footnoteAAffil{Another University}\footnoteANote{Corresponding author}\footnoteANote{Equal contributors}
        \and
        Prince Charming\FootnotemarkAAffil{2}\FootnotemarkANote{2}
}
\date{\today}


\begin{document}
\maketitle
\end{document}

And the output I get is:

enter image description here

Thanks for the help!

2

There are many separate problems with your code.

Wrong symbols

For the second author you used \FootnotemarkAAffil{2}. That is the incorrect syntax. The correct one should be \footnotemarkAAffil[2] (note the lower case and the square brackets). The former prints the argument (literally) as the footnotemark. The latter prints the footnotemark associated to the optional argument.

Using footmisc

Some years ago there was some discussion about whether footmisc is compatible with bigfoot. I don't know the status of the mutual compatibility, but the package mentioned in the linked question (fnpct) definitely is compatible with bigfoot.

Spacing issues

A main problem, however, is that of spacing. The reason the spacing is somewhat borked is because, while normally we have the kernel definition

\def\@makefnmark{\hbox{\@textsuperscript{\normalfont\@thefnmark}}

In article.cls we see that during \maketitle this is redefined (unless you use the titlepage option):

\newcommand\maketitle{\par
    \begingroup
      \renewcommand\thefootnote{\@fnsymbol\c@footnote}%
      \def\@makefnmark{\rlap{\@textsuperscript{\normalfont\@thefnmark}}}%
...

The \rlap causes that weird spacing you see. To get around this problem you have to either redefine the \maketitle command or use the titlepage option.

If you weren't using the bigfoot package, then you can just adapt this answer.

Footnotes not showing up

Standard article class sets the author list using a tabular. Tabulars are known to not play well with footnotes (and many other discussion here on TeX.SE). To work around that the \thanks macro is used (which basically streamlines the \footnotemark...\footnotetext call one uses with tabulars). The \footnote command is also redefined to become \thanks.

What is key is that these redefinitions are not duplicated by bigfoot.

An not-so-elegant solution

\documentclass[titlepage]{article}  % <---- Use titlepage option for the rlap problem

\title{My title}

\usepackage[dont-mess-around]{fnpct}   % <---- I use fnpct instead of footmisc, but that's probably not essential
\usepackage{bigfoot}

\DeclareNewFootnote{AAffil}[arabic]
\DeclareNewFootnote{ANote}[fnsymbol]

% Hook into the \thanks command for the article class to print the footnotes
\makeatletter
\def\thanksAAffil#1#2{
    \protected@xdef\@thanks{\@thanks
        \protect\footnotetextAAffil[#1]{#2}}%
}
\def\thanksANote#1#2{
    \protected@xdef\@thanks{\@thanks
        \protect\footnotetextANote[#1]{#2}}%
}
\makeatother

\author{%
        David Kaplan\footnotemarkAAffil\footnotemarkAAffil\footnotemarkANote\footnotemarkANote%
        \thanksAAffil{1}{A University}\thanksAAffil{2}{Another University}\thanksANote{1}{Corresponding author}\thanksANote{2}{Equal contributors}%
        \and%
        Prince Charming\footnotemarkAAffil[2]\footnotemarkANote[2]%
}
\date{\today}


\begin{document}
\maketitle

Text
\end{document}
  1. As mentioned above, using titlepage will work around the overlapping issue.
  2. To solve the issue of footnotes not showing up, I initially tried to copy (after looking at Werner's excellent explanation) the definition of \thanks to apply them to the new footnotes from bigfoot. However, this breaks how fnpct detects consecutive footnotes, and the commas become suppressed, and so;
  3. You must manually issue \footnotemarkAAffil etc to mark all the footnotes, to take advantage of the commas that are generated, and then use the \thanksAffil etc commands (that are defined in the code above) to supply the footnote texts that will be displayed on the title page.

Output:

enter image description here

0
0

Thanks Willie Wong for your solution, this is extremely helpful and taught me a lot about how things actually work under the hood.

Your solution is perfect except for two things. One is that I don't want to use titlepage. I fixed the spacing issue without titlepage using the patchcmd from etoolbox, which seems to work even with bigfoot:

\usepackage{etoolbox}
\makeatletter
\patchcmd\maketitle{\def\@makefnmark{\rlap{\@textsuperscript{\normalfont\@thefnmark}}}}{}{}{}
\makeatother

The other problem is that I want commas between author names. When I replace \and by , , this left lots of empty space around author names. I realized this was due to some missing comments (%) in the definition of \thanksAAffil and \thanksANote.

And finally, I decided not to use the fnpct package, instead putting in by hand $^{,}$ and placing the \footnotemarkAAfil and \footnotemarkANote directly in the corresponding thanks commands.

Given all this, my final working solution is:

\documentclass{article}  % <---- No titlepage

\title{My title}

%\usepackage[dont-mess-around]{fnpct}   % <---- I decided not to use fnpct, but rather put in the commas by hand
\usepackage{bigfoot}

\DeclareNewFootnote{AAffil}[arabic]
\DeclareNewFootnote{ANote}[fnsymbol]

\usepackage{etoolbox}
\makeatletter
\patchcmd\maketitle{\def\@makefnmark{\rlap{\@textsuperscript{\normalfont\@thefnmark}}}}{}{}{}
\makeatother

% Hook into the \thanks command for the article class to print the footnotes
% Now include \footnotemarkXXXX commands
\makeatletter
\def\thanksAAffil#1{% <--- These %'s are necessary for spacing
  \footnotemarkAAffil\protected@xdef\@thanks{\@thanks%
        \protect\footnotetextAAffil[\the \c@footnoteAAffil]{#1}}%
}
\def\thanksANote#1{%
  \footnotemarkANote%
  \protected@xdef\@thanks{\@thanks%
        \protect\footnotetextANote[\the \c@footnoteANote]{#1}}%
}
\makeatother

\author{% <---- Not sure if these %'s are necessary, but can't hurt
  David Kaplan%
  \thanksAAffil{A University}$^{,}$\thanksAAffil{Another University}$^{,}$%
  \thanksANote{Corresponding author}$^{,}$\thanksANote{Equal contributors}%
  , %
  Prince Charming%
  \footnotemarkAAffil[2]$^{,}$\thanksAAffil{Still another university}$^{,}$\footnotemarkANote[2]$^{,}$%
  \thanksANote{Another note}%
  , %
  Mohamed Ali%
  \thanksAAffil{I am the badest U}%
}
\date{\today}

\begin{document}
\maketitle

\begin{abstract}
  This is the abstract.
\end{abstract}

\section{Introduction}

More Text

\end{document}

This produces:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.