1

After updating arara, I have a problem when I run it:

% arara: pdflatex
\documentclass[11pt]{article}
\begin{document}
Test
\end{document}

C:\Users\Name\Documents\arara test.tex

Give me:

  __ _ _ __ __ _ _ __ __ _
 / _` | '__/ _` | '__/ _` |
| (_| | | | (_| | | | (_| |
 \__,_|_|  \__,_|_|  \__,_|

Exception in thread "main" java.nio.file.InvalidPathException: Illegal char <<> at index 0: <arara> @{userhome}\arara\rules
        at sun.nio.fs.WindowsPathParser.normalize(Unknown Source)
        at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
        at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
        at sun.nio.fs.WindowsPath.parse(Unknown Source)
        at sun.nio.fs.WindowsFileSystem.getPath(Unknown Source)
        at java.nio.file.Paths.get(Unknown Source)
        at org.islandoftex.arara.mvel.configuration.LocalConfiguration$toExecutionOptions$preprocessedPaths$3.invoke(LocalConfiguration.kt:78)
        at org.islandoftex.arara.mvel.configuration.LocalConfiguration$toExecutionOptions$preprocessedPaths$3.invoke(LocalConfiguration.kt:78)
        at kotlin.sequences.TransformingSequence$iterator$1.next(Sequences.kt:210)
        at kotlin.sequences.TransformingSequence$iterator$1.next(Sequences.kt:210)
        at kotlin.sequences.TransformingSequence$iterator$1.next(Sequences.kt:210)
        at kotlin.sequences.SequencesKt___SequencesKt.toCollection(_Sequences.kt:786)
        at kotlin.sequences.SequencesKt___SequencesKt.toSet(_Sequences.kt:827)
        at org.islandoftex.arara.mvel.configuration.LocalConfiguration.toExecutionOptions(LocalConfiguration.kt:86)
        at org.islandoftex.arara.cli.configuration.ConfigurationUtils.load(ConfigurationUtils.kt:73)
        at org.islandoftex.arara.cli.CLI.run(CLI.kt:215)
        at com.github.ajalt.clikt.parsers.Parser.parse(Parser.kt:204)
        at com.github.ajalt.clikt.parsers.Parser.parse(Parser.kt:17)
        at com.github.ajalt.clikt.core.CliktCommand.parse(CliktCommand.kt:396)
        at com.github.ajalt.clikt.core.CliktCommand.parse$default(CliktCommand.kt:393)
        at com.github.ajalt.clikt.core.CliktCommand.main(CliktCommand.kt:411)
        at com.github.ajalt.clikt.core.CliktCommand.main(CliktCommand.kt:436)
        at org.islandoftex.arara.cli.CLIKt.main(CLI.kt:290)

It is arara version 6.1.1, java version 1.8.0_291 and miktex version 21.6.28

I'm on Windows 10.

5
  • works ok for me, but my java version is a bit older. Jul 10, 2021 at 18:09
  • 1
    See the CHANGELOG for version 6. It's a documented and intended change to remove the arara shorthand syntax. Simply use the more elaborate syntax that has been there for a few versions and you are fine.
    – TeXnician
    Jul 10, 2021 at 19:47
  • @UlrikeFischer I will uninstall reinstall arara, miktex and java to try. @TeXnician, the quickstart guide from 6.0.1 release use the arara command.
    – Arnaud
    Jul 11, 2021 at 14:20
  • 1
    @Arnaud Paulo sent me an special yaml for a test, with it I got the error to. So I think you have some special settings somewhere. Jul 11, 2021 at 14:30
  • 1
    I am writing an answer right now. Jul 11, 2021 at 14:30

1 Answer 1

4

(arara developer here)

Looking closely at exception thrown,

Illegal char <<> at index 0: <arara> @{userhome}\arara\rules

I can determine the error is located in your configuration file (araraconfig.yaml or similar name). In series 5 (as seen in the corresponding CHANGELOG entry and issue #26), the <arara>shorthand was marked as deprecated and announced to be removed in the next major version (series 6). That's why an update from 5 to 6 "crashed". :)

I would guess your configuration file currently looks like

!config
paths:
- <arara> @{userhome}\arara\rules

There are two issues:

  • The <arara> shorthand is no more, so we need to remove it.
  • The {@userhome} was replaced my @{user.home} so we need to updated.

A new configuration file would be:

!config
paths:
- '@{user.home}\arara\rules'

That would solve the issue.

Hope it helps. :)

1
  • 2
    Thank you very much @PauloCereda, It works now ! Thank you too Ulrike Fischer for your responsiveness !
    – Arnaud
    Jul 11, 2021 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.