2

Problem

I am using a custom document class from a book publishing company. When I include the fontawesome5 in it, the compilation gives me a mapping error. If I do not use the custom document class then everything compiles fine. For this reason, it may not make much sense to provide a MWE since it is a custom document class. I have an older version of fontawesome installed and it works fine.

Errors

/usr/local/texlive/2021/texmf-dist/tex/latex/fontawesome5/fontawesome5-mapping.def:22: LaTeX3 Error: Control sequence \faAdjust already defined.

For immediate help type H <return>.
...                                              
                                              
l.22 ...:nnnnn{\faAdjust}{adjust}{free0}{3}{"F042}

Questions

  • I could not see it in the official documentation, but does fontawesome5 support PDFLaTeX?
  • I have managed to get fontawesome5 to work with XeTeX and LuaTeX, but less successful with PDFLaTeX. How should I interpret the error message and is there a solution?
  • I have also tried to install the fontawesome.otf font in my system (macOS Big Sur), but that did not seem to help. Is there something I could do to make latex recognize the font?

Official documentation

2
  • 1
    Yes, it does work with pdfLaTeX. Everything else is hard to say without seeing a MWE or at least the documentclass causing issues. But if I had to guess I would think that the class already loads he old fontawesome package. Loading both doesn't work since they define the same names. Jul 11, 2021 at 0:34
  • @MarcelKrüger This was the problem, the document class loaded the old fontawesome package. Once I commented it out, everything worked. Thanks!
    – kexxcream
    Jul 11, 2021 at 8:23

1 Answer 1

3

The error message Control sequence \faAdjust already defined. indicates that the command \faAdjust already existed before fontawesome5 tried to define it. In most cases this indicates that the old fontawesome package (which defined the same icon name) has been loaded.

Since the fontawesome and fontawesome5 packages share many command names, it is not possible to load both of them in the same document. So in order to use fontawesome5, \usepackage{fontawesome} has to be removed first.

After that you can use fontawesome5 on all common engines (LuaLaTeX is recommended, but XeLaTeX, pdfLaTeX and classical (DVI based) LaTeX work too).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .