0

I am using TinyTex in Ubuntu. I like the "small and simple" philosophy of TinyTex, and it works really well with R and RStudio using RMarkdown.

But I have some documents I'd like to work with in the traditional LaTeX fashion. There was some pain in installing missing LaTeX packages, but I think I have all of the ones I need. My paper compiles and displays in TexWorks.

The problem I have is installing custom BST files for natbib. I can't for the life of me figure out where to put them so that TinyTex can see them. I've tried the same directory as the document, ~/.TinyTex/texmf-dist/bibtex/bst, ~/.TinyTex/texmf-local/bibtex/bst.

No matter where I put it, I get the following error when I try to compile with BibTex:

This is BibTeX, Version 0.99d (TeX Live 2020/Debian)
The top-level auxiliary file: ....
I couldn't open style file apsr.bst
---line 86 of file ...
 : \bibstyle{apsr
 :               }
I'm skipping whatever remains of this command
I found no style file---while reading file ...
(There were 2 error messages)

What can I do?

6
  • Isn't TinyTeX just a cut down TeX Live? Did you try ~/texmf/bibtex/bst/?
    – Joseph Wright
    Jul 19, 2021 at 14:00
  • @JosephWright yes but there's no such directory. just the two I mentioned -- /texmf-local and /texmf-dist
    – bshor
    Jul 19, 2021 at 15:40
  • Where are the other bst files located? Presumably you can put your custom style in that folder. kpsewhich plain.bst in the terminal should give you the location.
    – Marijn
    Jul 20, 2021 at 7:47
  • That sounds like a good way to go, but I don't have kpsewich! Ubuntu tells me I need to install texlive binaries ... what I wanted to avoid the whole time :)
    – bshor
    Jul 20, 2021 at 19:34
  • In that case just sudo find . -name "plain.bst" from root (cd /, not cd ~).
    – Marijn
    Jul 21, 2021 at 10:17

1 Answer 1

0

Yihui Xie (author of TinyTex) solved this problem here.

The issue is that I installed TinyTex first, and then I installed my LaTeX editor. When I did that, it automatically installed texlive for me, despite the fact that I had TinyTex installed already. So that when I was putting in these bst files into the TinyTex local directories, it was never seeing them!

The solution was to install my LaTeX editor with the --no-install-recommends option (on Ubuntu with apt) so that it didn't bring along texlive.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .