1

Completely new to LaTeX environment. So I'm using TexMaker for my Masters thesis. I thought I set it up correctly but this issue keeps cropping up.

First, there is one instance if when I use \gls{example} and then compile using quick build that it gives me the error

! Package glossaries Error: Glossary entry `{example}' has not been defined.

The funny thing is that it has been defined and has been used called multiple time before and after alongside newly defined abbreviations. It works fine when I comment this specific call.

So, I thought maybe I would have to run the makeglossaries user command. But when I do that I get the following error:

2021/07/20 17:44:28 Rollbar error: empty token

panic: runtime error: invalid memory address or nil pointer dereference [signal 0xc0000005 code=0x0 addr=0x0 pc=0x956a1c] goroutine 1 [running]:

github.com/ActiveState/cli/internal/locale.T(0x1604a9a, 0x15, 0x0, 0x0, 0x0, 0x17a7c80, 0x8) D:/a/cli/cli/internal/locale/locale.go:119 +0x5c github.com/ActiveState/cli/internal/language.init() D:/a/cli/cli/internal/language/language.go:69 +0x4e

Now I'm not sure what it means but a friend set up a Github repository so that I can work remotely. I have not really utilised it for that but did upload just to back up my work. Not sure if that is causing the underlying issue here.

Also the whole time \printglossaries does not update with new abbreviations. I didn't mind since I was working on the main body but I think it may be related.

Last, the \gls{example} is inside a \hl{} call. This didn't matter a few days ago when it worked perfectly.

Any help would be appreciated.

1 Answer 1

0

Ok so I had the same problem and a really hard time figuring out where it was comming from. Glossaries was working fine untill I decided to turn the folder my TeX document was in into a git repository. It seems like somehow this git folder interacts with the Perl installation from active Perl, corrupting a configuration file from Perl.

So there are probably three options which may work.

  1. Delete the .git folder and turn the repository back into a normal folder This is explained here https://findanyanswer.com/can-i-delete-git-folder#:~:text=1%20Start%20--%3E%20Run.%202%20Type%3A%20cmd.%203,%2FS%20%2FQ%20%2FA%20.git.%206%20and%20rmdir%20.git. though I was scared to accidentally delete everything and didn't try it. If you go for this method you may also have to delete the corrupted configuration file.

  2. Try to solve the underlying issue with Perl. This user did seem to have a similar problem Runtime Error on Compilation when using Latexmk and the solution was to delete a corrupt configuration file and reinstall Perl. It seems like this issue was common with an older Perl version and fixed in newer distributions.

  3. Try to compile everything with overleaf or another web based LaTeX application and hope that it runs there.

I personally went for option two since I didn't want to turn the repository into a normal folder again. First I had a lot of trouble with it but than I installed Strawberry Perl instead of active state Perl and updated the path variable (In windows you have to got to system variables and insert the path where perl.exe is in into the Path variable). Afterwards I restarted my computer and it finally worked again.

I hope this was somewhat helpful!

1
  • Welcome to TeX.SE!
    – Mensch
    Nov 5, 2021 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.