1

I switched from LaTeX to ConTeXt and I am pulling my hair creating a simple column.

When I use a minimal setup like this:

\setuppapersize[A4]
\starttext
\startcolumns[n=3]
\input knuth
\stopcolumns
\stoptext

according to the https://wiki.contextgarden.net/Columns, what I get is this output, in which text in columns is not correctly aligned:

enter image description here

I tried to look through all wikis, handbooks etc, but when this minimalist code sample doesn't show desired results, is there a problem with the installation?

2
  • 1
    You would get the same in latex e.g. with multicols if you would force \fussy settings. Small columns have difficulties to align. Find out how to allow more space in the lines (in LaTeX I would e.g. try \emergencystretch 1em). Jul 23, 2021 at 9:25
  • @UlrikeFischer ConTeXt provides the two options stretch and extremestretch for \setupalign (and the align key) which use \emergencystretch, e.g. \setupcolumns[align=stretch] but it is recommended to combine them with other options like tolerant (\setupcolumns[align={tolerant,stretch}]). Jul 26, 2021 at 20:17

1 Answer 1

0

Setting align to verytolerant works (as Wolfgang Schuster pointed out in the comments):

\setuppapersize[A4]

\starttext

\startcolumns[n=3, align=verytolerant]
\input knuth
\stopcolumns

\stoptext

enter image description here

4
  • Thanks, I used setupcolumns with verytolerant, but that did not affect the output. It's a bit frustrating to learn when even a minimal example does not work as inteded like the wiki or manual :(
    – Chris
    Jul 23, 2021 at 10:15
  • This is very frustrating indeed and obviously a bug. You should report it on the mailing list
    – DG'
    Jul 23, 2021 at 10:36
  • 1
    @DG' Use the align key to set the tolerance, e.g. \setupcolumns[align=verytolerant]. Jul 24, 2021 at 11:57
  • Thanks, @WolfgangSchuster! Works like a charm
    – DG'
    Jul 24, 2021 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .