3

i have a document ike this:

\documentclass[12pt,openany]{book}      % paper size is in preamble.sty

\usepackage[T1,T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english,russian]{babel}

%%%%%%%%% GRAPHICS %%%%%%%%%%%%%%
\usepackage{graphicx}
\graphicspath{{images/}}

\usepackage{csquotes}

%%%%%%%%%% BOOK INFORMATION %%%%%%%%%%
\newcommand{\authorname}{AUTHOR}
\newcommand{\booktitle}{TITILE}
\newcommand{\subtitle}{SUBTITILE}
\newcommand{\publisher}{PUBLISHER}
\newcommand{\editionyear}{2021}
\title{\booktitle}
\author{\authorname}

\usepackage{misc/options}

\begin{document}
\frontmatter
\input{frontmatter/titlepage}
\input{frontmatter/preface}
\input{frontmatter/tocpage}

\mainmatter
\pagestyle{fancy}

\input{content/chapter1}

\end{document}

My options like here:

\usepackage[activate={true,nocompatibility},final,tracking=true,kerning=true,spacing=true,factor=1100,stretch=10,shrink=10, babel=true]{microtype}   % Better typography

\usepackage{lettrine}   % Add drop caps to chapter openings
\usepackage{graphicx}
\usepackage{ebgaramond}

\newcommand{\hsp}{\kern 1pt}    % for nested quotation marks

% Paragraph formatting
\renewcommand{\baselinestretch}{1.125}      % Allow paragraphs to breathe by spreading the lines further
\setlength{\parskip}{0pt}                   % Fixed space between paragraphs (i.e. disable variable parskip)
\setlength{\parindent}{1em}

% Don’t add extra space after sentences
\frenchspacing

% Reduce widows/orphans
\widowpenalty=10000
\clubpenalty=10000

% Page size
\usepackage[
    paperheight=9in,
    paperwidth=6in,
    top=0.75in,
    bottom=0.75in,
    outer=0.75in,
    inner=0.875in
]{geometry}

% Reduce overfull \hbox{} warnings
\sloppy

% Contents page
\usepackage[titles]{tocloft}
\renewcommand{\cftchapfont}{\large\itshape}
\renewcommand{\cftchappagefont}{\normalfont}
\renewcommand{\numberline}[1]{}

% chapter headings
\renewcommand\thechapter{\Roman{chapter}}
\usepackage[center,sc]{titlesec}

% headers/footers
\usepackage{fancyhdr}
\setlength{\headheight}{15pt}
\pagestyle{fancy}
\fancyhf{}
\renewcommand{\headrulewidth}{0pt}
\fancyhf[CFE,CFO]{\thepage}         % Set page numbers in the footer
%\fancyhead[LE,RO]{\thepage}        % Set page numbers in the left/right sides of the header
%\fancyhead[CE]{\itshape\authorname} % Author name in middle of left-side page header
%\fancyhead[CO]{\itshape\booktitle}  % Book title in middle of right-side page header

But when I try to make my text (in some chapters) bold using \textbf{my text} command I don't see anything change. Any idea what's going on ? Maybe it's because I use Russian in addition to English?

textbf Here is example textbf doesnt work

Also i have a little message

7
  • 1
    Are you loading amsmath?
    – egreg
    Jul 23 at 14:56
  • @egreg No, I don't need mathematical formulas. I just added the command to add this package and nothing has changed. Jul 23 at 14:59
  • Can you please add some paragraphs that illustrate what doesn't work?
    – egreg
    Jul 23 at 15:00
  • 2
    @egreg I rather think that ebgaramond is the problem. I'm not sure cyrillic glyphs work with pdftex.
    – campa
    Jul 23 at 15:06
  • 1
    @campa I just commented out this package and everything worked! thank you! Jul 23 at 15:09
8

Your problem can be reproduced by the shorter code

\documentclass{article}
\usepackage[T1,T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english,russian]{babel}
\usepackage{ebgaramond}
\begin{document}
Chapter, Глава, \textbf{Chapter}, \textbf{Глава}
\end{document}

which results in enter image description here

The trouble is that ebgaramond with pdftex does not support the T2A encoding. In fact, the console shows the warnings

LaTeX Font Warning: Font shape `T2A/EBGaramond-OsF/m/n' undefined
(Font)              using `T2A/cmr/m/n' instead on input line 6.

LaTeX Font Warning: Font shape `T2A/EBGaramond-OsF/bx/n' undefined
(Font)              using `T2A/EBGaramond-OsF/m/n' instead on input line 7.

Following the expansion of \begin{document} on line 6, TeX finds the macro \normalsize and tries to set up the font, which after loading ebgaramond should be T2A/EBGaramond-OsF/m/n. However, this font does not exists: the solution to this conundrum is provided by the file t2aenc.def, which contains (more or less) the line

\DeclareFontSubstitution{T2A}{cmr}{m}{n}

which means "if you are using the T2A encoding and you don't find the declared font, then fall back to cmr instead". LaTeX then switches to the font T2A/cmr/m/n, and warns you about it.

Then, on line 7 \textbf triggers boldface, and LaTeX looks for T2A/EBGaramond-OsF/bx/n. However, also this does not exists, and as replacement TeX uses the normal (non-bold) font, but that has been also replaced before! The result is that you don't get anything bold.

You could remove the fontenc and inputenc lines and use a Unicode-aware engine like luatex. However, Garamond doesn't have boldface anyway, so unless you want to start setting up different fonts for English/Russian, the easiest solution is to remove ebgaramond.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.