140

I don't know how to cite a chapter written by an author who is not the editor or author of the book.

How can I get the following citation?

Grandstrand, O. (2004), 'Innovation and Intellectual Property Rights', in J. Fagerberg, D.C. Mowery and R.R. Nelson (Eds.), Oxford Handbook of Innovation. Oxford University Press: Oxford.

4 Answers 4

171

I believe that the entry type you want to use is called @incollection.

Back-filling information for the author's and editors' first names as well as the chapter and pages fields, the full entry could be as follows:

@incollection{grandstrand:2004,
  author      = "Ove Grandstrand",
  title       = "Innovation and Intellectual Property Rights",
  editor      = "Jan Fagerberg and David C. Mowery and Richard R. Nelson",
  booktitle   = "The Oxford Handbook of Innovation",
  publisher   = "Oxford University Press",
  address     = "Oxford",
  year        = 2004,
  pages       = "266-290",
  chapter     = 10,
}

Using the plain bibliography style would generate the following typeset entry:

enter image description here

Addendum: If you use the chicago bibliography style, you'll get:

enter image description here

Here's the code used to generate the two preceding screenshots:

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
    @incollection{grandstrand:2004,
      author      = "Ove Grandstrand",
      title       = "Innovation and Intellectual Property Rights",
      editor      = "Jan Fagerberg and David C. Mowery and Richard R. Nelson",
      booktitle   = "The Oxford Handbook of Innovation",
      publisher   = "Oxford University Press",
      address     = "Oxford",
      year        = 2004,
      pages       = "266-290",
      chapter     = 10,
    }
\end{filecontents}

\documentclass{article}
\bibliographystyle{plain} % or: "chicago"
\usepackage{natbib} % a citation management package

\begin{document}   
\nocite{*}
\bibliography{mybib}
\end{document}
7
  • This is perfect... But if you use another style, like Chicago Style, you can not see the author of the book.
    – mmc
    Jun 22, 2012 at 17:34
  • 1
    If you use Chicago style, I would recommend using biblatex-chicago, and following the most current edition of the manual (16th). The format shown is not current Chicago style. Sep 9, 2014 at 13:32
  • 1
    @FangJing - Not sure I undestand your question. Most bibliography style files I'm familiar with contain a function which automatically "dashifies" the - character if it occurs in the pages` field, i.e., changes it to an en-dash. Do check both screenshots I posted: sure enough, they feature an en-dash, not a simple dash, between the page numbers. In short pages = "266-290", and pages = "266--290", produce the same output with most bib styles I'm familiar with.
    – Mico
    Nov 28, 2020 at 19:42
  • 1
    @Mico I see. That makes sense. Thank you!
    – tvk
    Nov 29, 2020 at 20:09
  • 1
    @Mico I deleted my comment to avoid confusion for future readers, since it was based on several wrong assumptions. I would be happy if you could do so too, as our conversation does not contribute to the problem.
    – Dunkelkoon
    Mar 6, 2021 at 22:17
43

Perhaps not exactly how you want it to appear (that requires probably selecting the right bibtex style) but here is something close with the standard:

\begin{filecontents}{test.bib}
@inbook{ X,
author = {O. Grandstrand},
chapter = {Innovation and Intellectual Property Rights},
crossref = {Y}
}

@book{ Y,
editor = {J. Fagerberg and D.C. Mowery and R.R. Nelson}, 
title      = {Oxford Handbook of Innovation},
booktitle = {Oxford Handbook of Innovation},
publisher = {Oxford University Press},
address = {Oxford},
year = 2004
}
\end{filecontents}

\documentclass{article}

\begin{document}

\nocite{*}

\bibliographystyle{plain}
\bibliography{test}

\end{document}

This results in

enter image description here

There are two reference here (both the chapter and the book) because I use \notcite on all antries. If just the chapter is cited then the result would be

enter image description here

The problem is that most if not all styles (that I know of) do not use both author and editor in a single entry even though it would make a lot of sense here. They only do that for @inproceedings and @incollection (I see that you found the latter by now yourself).

By default, BibTeX adds a separate citation to the whole book cross referenced when there are 2 or more different citations that crossref a complete work (even if the complete work is not explicitly cited anywhere. On modern BibTeX implementations this can be customized when running BibTeX by using the switch --min-crossref=<number>.

6
  • This is not what I am looking for as I want just to cite the chapter, and not the book.... I use Chicago or Harvard style, I forgot to mention...
    – mmc
    Jun 22, 2012 at 16:51
  • This is due to me citing all entries (see updated answer). However the form "In XYZ" is only used by BibTeX (min most styles) for @incollection or @inproceedings. Jun 23, 2012 at 6:58
  • 2
    When using biblatex, you may create a biblatex.cfg in your document root containing a line: \ExecuteBibliographyOptions{mincrossrefs=99} to customize the min-crossref setting.
    – math
    Feb 14, 2014 at 12:19
  • Thank you!!! This is exactly what I was looking for when I searched and found this question. Species description by Say in 1823 - in his field notes included as a chapter in a book he isn't credited as author of. Perfect match for this solution. Aug 24, 2021 at 1:12
  • 1
    Thanks for mentioning crossref! Apr 20, 2023 at 12:12
14

use

@inbook{test,
  author={Grandstrand, O.},
  year= 2004, 
  chapter={Innovation and Intellectual Property Rights}, 
  editor = {J. Fagerberg and D. C. Mowery and R. R. Nelson}, 
  title= {Oxford Handbook of Innovation}, 
  publisher= {Oxford University Press},
  address= {Oxford}, 
}

with biblatex and style authoryear I'll get:

enter image description here

4
  • 3
    that somehow comes out wrong, the chapter title is in the "in ..." part where it doesn't belong. Problem with biblatex? Jun 22, 2012 at 15:30
  • 1
    here, the title of the chapter is missing...
    – mmc
    Jun 22, 2012 at 17:23
  • 2
    @mmc no not missing, but in a strange place at the end of the entry. I think the resulting entry is wrong for this reason Jun 23, 2012 at 7:25
  • @FrankMittelbach This is not a problem with biblatex - rather with the style authoryear. The style chicago-authordate looks about right, especially if one changes title into booktitle
    – cgnieder
    Jan 25, 2013 at 19:38
2

I tried using CROSSREF, but I found that the \nocite{*} generated too many entries. I don't want all entries in my BIB file to show up in the References section of my paper. The problem is that, without \nocite{*}, the book which contains the chapter/section that I'm citing does not show up. I managed to solve this by citing the book from within the \phantom command. So in the context of Frank Mittelbach's example, I would have the commend \phantom{\cite{Y}} somewhere in my document. I placed it before the \cite{X} (the chapter/section within book Y in Frank Mittelbach's example).

Afternote: Darn. It didn't really have the desired effect. I have unwanted white space where the citation would have been made. This is exactly how \phantom should work, so I don't know what I was thinking. Can anyone suggest another way to hide the dummy citation to Y? The only reason why it's there is so that the CROSSREF in X is properly handled. Maybe a way to impose a zero-size font onto the dummy citation? Using \fontsize and \selectfont to specify 0pt causes an error, so I tried making the dummy citation white: \textcolor{white}{ \fontsize{1pt}{1pt}\selectfont \cite{Y} }. This only makes the square brackets around the bibliography entry number white.

I guess @incollection is the way to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .