0

I am new to beamer, and unfortunately, I am getting aspect ratio problem. I am working with beamer template warsaw by Till Tantau. It is working fine but I would like to use the landscape orientation. For that, I changed the aspect ratio in document settings--document class--custom--aspectratio=169, ,10pt. and I am using these packagers in the preamble;

\usepackage[orientation=landscape,size=custom,width=16,height=9,scale=0.5,debug]{beamerposter} %%%%self for aspect ratio

\usepackage{bookmark}

\hypersetup{bookmarksdepth=4,bookmarksnumbered=true,bookmarksopen=true}

\setcounter{tocdepth}{1}
% or ...

\setbeamercovered{transparent}
% or whatever (possibly just delete it)

%\usepackage{palatino}%
\usepackage[sc]{mathpazo}
\beamertemplatenavigationsymbolsempty

%Set Presentation mode and colors
%--------------------------------------------------------
\mode<presentation> {
  \setbeamertemplate{background canvas}[vertical shading][bottom=white,top=white]
  \usetheme{Warsaw}
  \usefonttheme[onlysmall]{structurebold}
 % default | professionalfonts | serif |
 %    structurebold | structureitalicserif |
 %    structuresmallcapsserif
}
\setbeamertemplate{navigation symbols}{}%remove navigation symbols

%Using packages
%--------------------------------------------------------
\usepackage{amsfonts}\usepackage{amsxtra}\usepackage{pgf}
%\usepackage{german} %%I changed it
\usepackage{graphicx}
\usepackage{float}
\usepackage{multirow}
\usepackage{units}
%\usepackage{multimedia}
\usepackage{color}
\usepackage{colortbl}
\usepackage{booktabs}
\usepackage{hyphenat}
\usepackage{movie15}
\graphicspath{{./picture/}}
\include{defs}
\usepackage{animate}


%Begin of the document
%--------------------------------------------------------

\setbeamertemplate{frametitle}[default][left] %%for setting frame titles to the left

%%to change font size
%\usepackage{scrextend}
%\changefontsizes{10pt}

Now the problem is it is changing the aspect ratio of body text not the frame. Here is the example picture; enter image description here

0

I believe that landscape orientation need to be applied by using following command:

% lscape.sty Produce landscape pages in a (mainly) portrait document.

\usepackage{lscape} ... \begin{landscape} ... \end{landscape}

You may refer to following articles: How to change certain pages into landscape/portrait mode

5
  • thanks for the response, should In add these packages to preamble?
    – Ajeen Lew
    Aug 4 at 9:55
  • yes. I suggest use this package at header and try to leverage on this whenever you need to convert your writing to landscape rather than try to change the ratio. Aug 4 at 9:58
  • Better try use it separately and share results Aug 4 at 10:04
  • I am trying but don't know what should I add between \begin{landscape} ... \end{landscape}
    – Ajeen Lew
    Aug 4 at 10:24
  • That part of document that you need to be in landscape. you may leave landscape orientation in beamerposter and just insert your content in landscape tag Aug 4 at 10:28
0

To control the aspect ratio and also size of the presentation, you only have to use:

\geometry{paperheight=<whatever>,paperwidth=<whatever>}

Decreasing the paper dimensions you can have a (relatively) larger font or viceversa, so ideally you do not need even to touch the default font settings.

MWE:

mwe

\documentclass{beamer}
\usetheme{Warsaw}
\geometry{paperheight=4.5cm,paperwidth=8cm}
\begin{document}
\begin{frame}{foo}
foo 
\end{frame} 
\end{document}
1
  • hey thanks for the response. But it is not working still getting the same result.
    – Ajeen Lew
    Aug 5 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.