3

Original question

I would like to make an identical copy of my Microsoft Word based CV in LaTeX. The Word document however makes use of Copperplate Gothic. I did not see Copperplate Gothic mentioned in the Computer Modern family, which I understand is the default family used in LaTeX.

How can I use Copperplate Gothic in my LaTeX based CV?

Edit as per @Mico's answer

I followed the accepted answer to [this question][1] to make sure that the desired fonts exist as system fonts. When I run the following command:

fc-list | grep "Copperplate"

I get the following result:

/mnt/c/Windows/Fonts/COPRGTL.TTF: Copperplate Gothic Light:style=Regular,Normal,obyčejné,Standard,Κανονικά,Normaali,Normál,Normale,Standaard,Normalny,Обычный,Normálne,Navadno,Arrunta
/mnt/c/Windows/Fonts/COPRGTB.TTF: Copperplate Gothic Bold:style=Regular,Normal,obyčejné,Standard,Κανονικά,Normaali,Normál,Normale,Standaard,Normalny,Обычный,Normálne,Navadno,Arrunta

I then tried to compile the document provided by @Mico using latexmk -luatex test.tex, but got an error:

Latexmk: This is Latexmk, John Collins, 26 Dec. 2019, version: 4.67.
Latexmk: applying rule 'lualatex'...
Rule 'lualatex': File changes, etc:
   Changed files, or newly in use since previous run(s):
      'test.tex'
------------
Run number 1 of rule 'lualatex'
------------
------------
Running 'lualatex  -recorder  "test.tex"'
------------
This is LuaTeX, Version 1.10.0 (TeX Live 2019/Debian)
 restricted system commands enabled.
(./test.tex
LaTeX2e <2020-02-02> patch level 2
[\directlua]:1: module 'luaotfload-main' not found:
        no field package.preload['luaotfload-main']
        [kpse lua searcher] file not found: 'luaotfload-main'
        [kpse C searcher] file not found: 'luaotfload-main'
Error in luaotfload: reverting to OT1 L3 programming layer <2020-02-14>
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2019/12/20 v1.4l Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size10.clo
(/usr/share/texmf/tex/latex/lm/ot1lmr.fd)))
(/usr/share/texlive/texmf-dist/tex/latex/fontspec/fontspec.sty
(/usr/share/texlive/texmf-dist/tex/latex/l3packages/xparse/xparse.sty
(/usr/share/texlive/texmf-dist/tex/latex/l3kernel/expl3.sty
(/usr/share/texlive/texmf-dist/tex/latex/l3backend/l3backend-pdfmode.def)))
(/usr/share/texlive/texmf-dist/tex/latex/fontspec/fontspec-luatex.sty
(/usr/share/texlive/texmf-dist/tex/latex/base/fontenc.sty
! Font \TU/lmr/m/n/10=[lmroman10-regular]:+tlig; at 10pt not loadable: metric d
ata not found or bad.
<to be read again>
relax
l.112 ...lt\familydefault\seriesdefault\shapedefault

?

Final edit

I ran the following command inspired by one of the comments in [this question][2]:

sudo apt-get install texlive-luatex

Compiling the .tex file after this install succeeded, and I was able to see Copperplate Gothic in my resulting pdf.

I find this quite strange because prior to installing texlive-luatex, I had done a apt list | grep "texlive" and could see that texlive-luatex was among the packages already installed.

But oh well... it works now... [1]: Can I permanently instruct xelatex in WSL to use fonts in C:\Windows\Fonts? If yes, how? [2]: ! Font \TU/lmr/m/n/10=[lmroman10-regular]:+tlig; at 10pt not loadable

1
  • 5
    use lualatex and \usepackage{fontspec}\newfontfamily\cgothic{Copperplate Gothic} Aug 13, 2021 at 14:39

1 Answer 1

7

Assuming Copperplate Gothic Light and Copperplate Gothic Bold are available as system fonts on your computer, the following code sould get you started.

\documentclass{article}
\usepackage{fontspec}
\setmainfont{Copperplate Gothic Light}[BoldFont = {Copperplate Gothic Bold}]

\begin{document}
Hello World, \textbf{Hello World}
\end{document}

Addendum, prompted by the OP's revisions/amendments to the query: Since the OP has installed the two font files in the (slightly non-standard?) folder /mnt/c/Windows/Fonts/, the instruction

\setmainfont{Copperplate Gothic Light}[%
     BoldFont = {Copperplate Gothic Bold},
     Path     = {/mnt/c/Windows/Fonts/}]

should provide enough information for LuaLaTeX and its luaotfload-tool utility to find the font files, create the required hash files, etc.

8
  • 2
    For the OP: this would require you to use LuaLaTeX or XeLaTeX, instead of pdflatex. Aug 13, 2021 at 18:59
  • 1
    @user32882 - I'm not sure I understand your follow-up. Are you saying that the Copperplate fonts aren't installed on your system?
    – Mico
    Aug 16, 2021 at 7:31
  • 1
    @user32882 - Assuming the fonts are indeed installed on your Ubuntu system, but apparently in a somewhat non-standard folder, you could add an option such as Path={some/nonstandard/font/path/}to the list of optional arguments of \setmainfont.
    – Mico
    Aug 16, 2021 at 7:38
  • 1
    @Mico I just made Copperplate a system font and edited my original question, would be awesome if you could take a look at the edit and provide some additional insight
    – user32882
    Aug 16, 2021 at 8:27
  • 1
    Nevermind... I finally got it...
    – user32882
    Aug 16, 2021 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.