I want to change the display style of chapters in my document. I use the fncychap package. Here are the settings :

\usepackage[glenn]{fncychap} % Pour changer les chapitres

When I run my code, the style doesn't change. I didn't find anything here or on internet about this issue. Here is my preamble :

% Format + encodage

% ----------------------------------------
% Package pour la conception d'un document
% ----------------------------------------
%\usepackage[obeyDraft]{todonotes} % Pour des boites dans la marge
% ----------------------------
% Packages pour la mise en page
% ----------------------------
\usepackage[inner=3cm,outer=1cm,top=3cm,bottom=3cm]{geometry} % Mise en page type livre
\usepackage{setspace} % \singlespacing ; \onehalfspacing ; \doublespacing
\usepackage{changepage} % Pour adjustwidth
% modification des titres
%\usepackage{titlesec} % Pour changer l'apparence des titres
% =======================================================
\usepackage[glenn]{fncychap} % Pour changer les chapitres
% -------------------------------------------------------
\usepackage{fontawesome} % Pour rajouter des symboles
\usepackage{lettrine} % Pour avoir des lettrines
\usepackage{sectsty} % Pour changer la couleur des titres
% ----------------------------
% Packages pour le mode math
% ----------------------------
% ----------------------------
% Packages pour le dessin
% ----------------------------
% libraries Tikz
% ---------------------------------
% En-tête et pied de page
\fancyhead[L]{\emph{Les petits carnets de l'ingénieur}}
\fancyhead[R]{Nicolas \textsc{Lesquoy}}
\fancyfoot[C]{\textbf{Page \thepage}}
% ----------------------------
% Packages pour le choix de la police
% ----------------------------
\usepackage{addfont} % Pour les lettres cursives très jolies
% ----------------------------
% Packages pour présenter du code
% ----------------------------

} % Python

  {á}{{\'a}}1 {é}{{\'e}}1 {í}{{\'i}}1 {ó}{{\'o}}1 {ú}{{\'u}}1
  {Á}{{\'A}}1 {É}{{\'E}}1 {Í}{{\'I}}1 {Ó}{{\'O}}1 {Ú}{{\'U}}1
  {à}{{\`a}}1 {è}{{\`e}}1 {ì}{{\`i}}1 {ò}{{\`o}}1 {ù}{{\`u}}1
  {À}{{\`A}}1 {È}{{\'E}}1 {Ì}{{\`I}}1 {Ò}{{\`O}}1 {Ù}{{\`U}}1
  {ä}{{\"a}}1 {ë}{{\"e}}1 {ï}{{\"i}}1 {ö}{{\"o}}1 {ü}{{\"u}}1
  {Ä}{{\"A}}1 {Ë}{{\"E}}1 {Ï}{{\"I}}1 {Ö}{{\"O}}1 {Ü}{{\"U}}1
  {â}{{\^a}}1 {ê}{{\^e}}1 {î}{{\^i}}1 {ô}{{\^o}}1 {û}{{\^u}}1
  {Â}{{\^A}}1 {Ê}{{\^E}}1 {Î}{{\^I}}1 {Ô}{{\^O}}1 {Û}{{\^U}}1
  {œ}{{\oe}}1 {Œ}{{\OE}}1 {æ}{{\ae}}1 {Æ}{{\AE}}1 {ß}{{\ss}}1
  {ű}{{\H{u}}}1 {Ű}{{\H{U}}}1 {ő}{{\H{o}}}1 {Ő}{{\H{O}}}1
  {ç}{{\c c}}1 {Ç}{{\c C}}1 {ø}{{\o}}1 {å}{{\r a}}1 {Å}{{\r A}}1
  {€}{{\euro}}1 {£}{{\pounds}}1 {«}{{\guillemotleft}}1
  {»}{{\guillemotright}}1 {ñ}{{\~n}}1 {Ñ}{{\~N}}1 {¿}{{?`}}1
} % Problème d'encodage

The document is composed of differents .tex files which are included in my main.tex file with \input{file}. Could someone help me solving this issue ?

  • Load sectsty before fncychap. But think twice before using the latter package, which produce very dubious results from a typographical point of view.
    – egreg
    Commented Aug 18, 2021 at 20:57
  • Thanks, it worked in a certain manner but the defined style isn't used correctly. I only have the font selected and not the lines that should be drawn, and that is true for any style I choose.
    – Elyo
    Commented Aug 19, 2021 at 10:04
  • The package option is Glenn, not glenn. And it produces one of the worst chapter heading I have ever seen.
    – egreg
    Commented Aug 19, 2021 at 10:19

1 Answer 1


You need to load sectsty before fncychap and to use the correct package option:


I mean, if you really want to get this peculiar chapter heading style.

enter image description here

  • I personnaly like the look of it, thank you for taking the time to help me.
    – Elyo
    Commented Aug 19, 2021 at 12:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .