0

Compiling my document produces the error, "File `biblatex-chicago.sty' not found. \addbibresource".

I'm using TeXstudio 3.0.4 on Linux Pop!_OS 21.04. The .sty file is, in fact, installed. Here's the output of tlmgr info biblatex-chicago:

package: biblatex-chicago
category: Package
shortdesc: Chicago style files for BibLaTeX
longdesc: This is a BibLaTeX style that implements the Chicago 'author-date' and 'notes with bibliography' style specifications given in the Chicago Manual of Style, 17th edition (with continuing support for the 16th edition, too). The style implements entry types for citing audio-visual materials, among many others. The package was previously known as biblatex-chicago-notes-df.
installed: Yes
revision: 59772
sizes: doc: 4269k, run: 1933k
relocatable: No
cat-version: 2.2
cat-license: lppl1.3
cat-topics: biblatex
collection: collection-bibtexextra

My MWE is the following, which adds two lines from a working TeXstudio template, including \usepackage[options]{biblatex-chicago} and \addbibresource{'path/to/resource.bib'}:

\documentclass[a4paper,12pt]{book}
\usepackage[utf8]{inputenc}
\usepackage{graphicx}
\usepackage[backend=biber, 
            authordate]{biblatex-chicago} % Error refers to this package
\addbibresource{'~/Dropbox/Manuscripts/mylib.bib'} % Error triggered on this line

\begin{document}

\author{TeXstudio Team}
\title{Simple Book Example}
\date{}

\frontmatter
\maketitle
\tableofcontents

\mainmatter
\include{./TeX_files/chapter01}
\include{./TeX_files/chapter02}

\backmatter

\end{document}

I've also tried another suggestion for a similar problem, which is to replace the direct call to biblatex-chicago and instead call biblatex and call the style in the option block, like this:

\usepackage[backend=biber, 
            authordate, style=chicago]{biblatex}

But that suggestion produces the same error. I'm not sure really where to go from here. Any help would be greatly appreciated.

4
  • Do you have multiple TeX systems installed on your machine? What do which -a tlmgr and which -a pdflatex return? Does the example work if you compile it from the command line instead of via your editor?
    – moewe
    Aug 19 at 18:00
  • \usepackage[backend=biber, authordate, style=chicago]{biblatex} is definitely wrong. But it should not produce the same error (File `biblatex-chicago.sty' not found.) because it definitely does not request that biblatex-chicago.sty be loaded. Instead you should get errors about undefined options (authordate) and a style that cannot be found (style=chicago).
    – moewe
    Aug 19 at 18:02
  • @moewe It seems I have three instances of both tlmgr and pdflatex, each in /usr/bin/, /bin/, and /usr/local/texlive/2021/bin/x86_64-linux/. When I compile from the command line (pdflatex --> biber --> pdflatex) it compiles correctly. After cleaning up .aux (and other supporting files) from the successful compilation, I tried again in TeXstudio and got the same error. Could this be a TeXstudio issue?
    – chaoborid
    Aug 19 at 19:32
  • The issue will be that your TeXstudio picks up a different TeX installation than your command line. So on your command line tlmgr tells you biblatex-chicago is installed, but TeXstudio uses another system where it apparently isn't installed. Unless you have good reasons to have several TeX systems around I suggest you remove all but one. (I can't tell you quite how, because I don't know how you installed these systems.)
    – moewe
    Aug 20 at 5:44
0

You need to refresh file name database in MiKTeX

enter image description here

2
  • The question mentions tlmgr, which is a TeX live utility. That would suggest that MikTeX is not really relevant to the question. Plus with both MikTeX and TeX live the file name database should be updated automatically when packages are installed, so one should rarely have to do that manually.
    – moewe
    Aug 19 at 17:57
  • Correct. I'm using TexLive not MikTex.
    – chaoborid
    Aug 19 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.