I have a very weird problem using the hyperref package. When I try to link an external web site it doesn't work and only show me the link which it is pointing to. I've tried this MWE:


Here's a link to \href{http://twitter.com/home}{Twitter}.


but the result is always negative. I click the link and it displays the toast with the web address. The weird fact though is that when I use the moderncv package and link my mail address with the macro \email it works, so I guess the problem is with my \hyperref but I can't figure out how to solve it.

closed as too localized by Joseph Wright Sep 13 '12 at 6:36

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SX! From your MWE I have no problems in opening the url. – Claudio Fiandrino Jun 26 '12 at 11:34
  • 2
    Hi Luigi, could you tell us your operating system, TeX distro and PDF viewer? :) – Paulo Cereda Jun 26 '12 at 11:36
  • The problem might be your pdf viewer's configuration and not LaTeX. What happens when you click a URL/link in a pdf that wasn't created with LaTeX? If the problem appears there, too, we should probably migrate this question to Super User. – doncherry Jun 26 '12 at 11:45
  • 2
    I've tried your MWE and it works perfect for me. I'm using pdfTeX, Version 3.1415926-2.4-1.40.13 (MiKTeX 2.9) and Package: hyperref 2012/05/13 v6.82q Hypertext links for LaTeX. I viewed the pdf with the actual SumatraPDF. Seems to be a problem of your installation? – Mensch Aug 6 '12 at 21:54
  • 1
    Luigi, you wrote about “I tried sudo apt-get …” This looks to me, as that you installed the outdated (!!!) TeX Live version from the repository of your Linux distro. Perhaps it includes an old version of hyperref with a bug, that was fixed later. See also How to install “ vanilla ” TeXLive on Debian or Ubuntu?. – Speravir Sep 12 '12 at 21:09

Browse other questions tagged or ask your own question.