1

I've been trying to use Manim and one of the packages it uses to compile LaTex formulas is calligra. I had no issue installing the other packages Manim required for LaTex, but the compiler still says, LaTeX Error: File 'calligra.sty' not found when I run pdflatex file_name.tex (an example file that triggers the error is shown below).

\documentclass[preview]{standalone}

\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{dsfont}
\usepackage{setspace}
\usepackage{tipa}
\usepackage{relsize}
\usepackage{textcomp}
\usepackage{mathrsfs}
\usepackage{calligra}
\usepackage{wasysym}
\usepackage{ragged2e}
\usepackage{physics}
\usepackage{xcolor}
\usepackage{microtype}
\DisableLigatures{encoding = *, family = * }
\linespread{1}

\begin{document}

\begin{align*}
x^2
\end{align*}

\end{document}

Tex-live-utility says the package is installed (I've uninstalled and reinstalled it a couple times). find <harddrive> -name "calligra.sty" shows no file (i.e. the calligra.sty wasn't just put in the wrong directory, it was never created in the first place). The only download I've found for a "calligra.sty" file is here: http://lcd-www.colorado.edu/~axbr9098/tmp/licentiate/calligra.sty I have no idea if it is the right one, and using it certainly didn't seem to work.

Is the calligra package no longer supported?

This was done with BasicTex, pdfTeX version 3.141592653-2.6-1.40.22 on mac os 11.5.2

4
  • 1
    Your example code only invokes math mode, whereas calligra is a text, not math, font. In addition, one must invoke \calligra in order to activate the font in text mode. If I add \calligra xyz to your document, I indeed get the text in the calligra font. Commented Sep 6, 2021 at 0:48
  • 1
    Apologies, I don't think I was specific enough. My issue isn't that I want to use the calligra package (I actually don't). However, Manim includes it in the tex_template file. Since I'm forced to use the calligra package by Manim—I've tried deleting it from the tex_template—I need to resolve this dependency issue. The above file was auto-generated by Manim. I do not intend to use calligra if I can avoid it. Commented Sep 6, 2021 at 1:02
  • I compiled your documents without problems. What does kpsewhich calligra.sty command produce on your system? On mine it produces /usr/local/texlive/2021/texmf-dist/tex/latex/fundus-calligra/calligra.sty
    – Boris
    Commented Sep 6, 2021 at 1:16
  • 1
    Thanks Boris, I get no output for kpsewhich calligra.sty. Your comment did give me a solution though. Downloading the fundus-calligra package in Tex Live Utility instead of the calligra package removes the error. Thanks for the help! Commented Sep 6, 2021 at 3:09

1 Answer 1

1

If I do tlmgr info calligra --list, I get

tlmgr info calligra --list
package:     calligra
category:    Package
shortdesc:   Calligraphic font
longdesc:    A calligraphic font in the handwriting style of the author,
             Peter Vanroose. The font is supplied as Metafont source.
             LaTeX support of the font is provided in the calligra package
             in the fundus bundle.
installed:   Yes
revision:    15878
sizes:       doc: 105k, run: 305k
relocatable: No
cat-license: other-free
cat-topics:  font font-calligraphic font-mf
cat-related: calligra-type1
collection:  collection-fontsextra
Included files, by type:
run files:
  texmf-dist/fonts/source/public/calligra/callig15.mf
  texmf-dist/fonts/source/public/calligra/calligra.mf
  texmf-dist/fonts/tfm/public/calligra/callig15.tfm
doc files:
  texmf-dist/doc/latex/calligra/README
  texmf-dist/doc/latex/calligra/testfont.pdf details="Font table"

and the longdesc field (edited here for readability) is quite clear.

Doing tlmgr info fundus yields

tlmgr: cannot find package fundus, searching for other matches:

Packages containing `fundus' in their title/description:
calligra - Calligraphic font
fundus-calligra - Support for the calligra font in LaTeX documents
fundus-cyr - Support for Washington University Cyrillic fonts
fundus-sueterlin - Sutterlin

and tlmgr info fundus-calligra --list finally produces

package:     fundus-calligra
category:    Package
shortdesc:   Support for the calligra font in LaTeX documents
longdesc:    The package offers support for the calligra handwriting font,
             in LaTeX documents. The package is part of the fundus bundle.
installed:   Yes
revision:    26018
sizes:       src: 13k, doc: 197k, run: 5k
relocatable: No
cat-version: 1.2
cat-license: other-free
cat-topics:  font-supp
collection:  collection-latexextra
Included files, by type:
run files:
  texmf-dist/tex/latex/fundus-calligra/calligra.sty
source files:
  texmf-dist/source/latex/fundus-calligra/calligra.dtx
  texmf-dist/source/latex/fundus-calligra/calligra.ins
doc files:
  texmf-dist/doc/latex/fundus-calligra/calligra.pdf details="Package documentation"

Thus both calligra and fundus-calligra need to be installed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .