1

I am trying to render the word LaTeX in an instructional PDF but am experiencing errors in Overleaf that I am not sure how to troubleshoot.

Here is the error message: enter image description here

To cross reference anything in \LaTeX\ you need to define a \hl{label}.
    For example, \emph{Chapters}, \emph{Sections}, \emph{Subsections},
    \emph{SubSubSections}, \emph{Paragraphs}, \emph{Figures}, and \emph{Tables}
    can be labeled in the following manner:

I am referencing \LaTeX\ multiple times throughout my PDF and am experiencing the same error message. I'm wondering if there is some sort of package clash.

Here is the rendered PDF: enter image description here

I am also experiencing a different error message \LaTeX{}. The PDF renders correctly but without the space after "LaTeX", but I cannot get rid of the error messages.

enter image description here

Any advice would be appreciated. I can link to Overleaf if that would be helpful to provide the .cls file. Thanks!

3
  • 8
    Locally you are doing everything correctly. More context is needed to debug. If there is a price for guessing, I'd say that you were trying to define \@command without making at letter. That is, you actually defined \@ which should always follows c, o, m, m, ...
    – Symbol 1
    Sep 16, 2021 at 5:19
  • 3
    please always include an example document that shows of the problem, but as Symbol1 says this is almost certainly a missing \makeatletter in code in your preamble. Sep 16, 2021 at 6:57
  • 2
    Is this the first error message reported? If not, you should be aware that once one error is reported, later "errors" may well be bogus, caused by the situation that triggered the first (genuine) error, and will go away once that is fixed. Oct 17, 2021 at 17:47

1 Answer 1

-1

The \ is a TeX command that expands to a space, needed as TeX deems spaces after a command (like \LaTeX) just end it, and get gobbled up.

A better solution (no strange spacing due to the forced \ space) is to write e.g. {\LaTeX} or \LaTeX{} (the group end/empty group does end the command, whatever may come next).

2
  • Really? Sorry, no. This is not the cause for the error and typing \LaTeX\ you need is completely equivalent to \LaTeX{} you need.
    – egreg
    Sep 17, 2021 at 16:46
  • Since the same error is being reported with \LaTeX{}. that is clearly not the answer. More information is needed to determine what is causing the problem. Oct 17, 2021 at 17:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.