1

I have a book anania:spumele. Inside is a chapter anania:mit:rom. This chapter is an article who was originally published in anania:rev. I want to have in footnote anania:mit:rom in anania:spumele, originally published as anania:rev

How do I put the crossref, related and relatedtype in my .bib file correctly using biblatex-chicago?

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[romanian]{babel}
\usepackage{csquotes}
\DeclareQuoteStyle{romanian}
{\quotedblbase}
{\textquotedblright}
{\guillemotleft}
{\guillemotright}

\usepackage[backend=biber,%
    abbreviate=false,%
    % backref=true,%
    % noteref=page,%
    cmsbreakurl,%
    sorting=nyt,%
    maxnames=3,%
    minnames=1,%
    isbn=false,%
    url=true,%
    date=long,%
    cmsdate=both,%
    bibencoding=inputenc,%
    bibannotesep=vpar,%
    booklongxref,%
    longcrossref=bib,%
  bookpages=true,%
    notes]
{biblatex-chicago}

\begin{filecontents}[force]{\jobname.bib}
@book{anania:spumele,
    editor    = {Frunză, Sandu},
    author    = {Anania, Valeriu},
    title     = {Din spumele mării},
    subtitle  = {Pagini despre religie și cultură},
    year      = {1995},
    publisher = {{Editura Dacia}},
    location  = {Cluj--Napoca},
    pagetotal = {245},
    isbn      = {9733504858},
    series    = {Colecția Homo Religiosus}
}
@inbook{anania:mit:rom,
    author      = {Anania, Valeriu},
    title       = {Mitologia românească},
    pages       = {118--124},
    crosreff    = {anania:spumele},
    related     = {anania:rev},
    relatedtype = {origpubas}
}
@article{anania:rev,
    author          = {Anania, Valeriu},
    title           = {Mitologia românească},
    journal         = {Revista de istorie și teorie literară},
    number          = {1--2},
    year            = {1987}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}

\autocite{anania:mit:rom}
\nocite{*}
\printbibliography
\end{document}

1 Answer 1

3

Your bib file set up is fine except for the typo in crossref.

By default biblatex-chicago only prints related entries in the bibliography. If you want to print them in the notes also, you must pass the option related=true to biblatex.

I had problems getting Romanian to work with my set up. biblatex doesn't seem to support all the required strings, but here's the output in English:

\documentclass{article}
\usepackage[abbreviate=false, cmsbreakurl, sorting=nyt, maxnames=3,
  minnames=1, isbn=false, url=true, date=long, cmsdate=both,
  bibencoding=inputenc, bibannotesep=vpar, booklongxref, longcrossref=bib,
  bookpages=true, related=true, notes]{biblatex-chicago}
\begin{filecontents}[overwrite]{\jobname.bib}
@book{anania:spumele,
  editor     = {Frunză, Sandu},
  author     = {Anania, Valeriu},
  title      = {Din spumele mării},
  subtitle   = {Pagini despre religie și cultură},
  year       = {1995},
  publisher  = {Editura Dacia},
  location   = {Cluj--Napoca},
  pagetotal  = {245},
  isbn       = {9733504858},
  series     = {Colecția Homo Religiosus}
}
@inbook{anania:mit:rom,
  author      = {Anania, Valeriu},
  title       = {Mitologia românească},
  pages       = {118--124},
  crossref    = {anania:spumele},
  related     = {anania:rev},
  relatedtype = {origpubas}
}
@article{anania:rev,
  author      = {Anania, Valeriu},
  title       = {Mitologia românească},
  journal     = {Revista de istorie și teorie literară},
  number      = {1--2},
  year        = {1987}
}
\end{filecontents}
\addbibresource{\jobname.bib}
\begin{document}
\null\vfill
\autocite{anania:mit:rom}
\nocite{*}
\printbibliography
\end{document}

output

1
  • It works here in Romanian! Thanks a lot!
    – Mafsi
    Commented Oct 18, 2021 at 15:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .