1

When trying to use pst-vectorian, I'm getting an error: GPL Ghostscript 9.54.0: Unrecoverable error, exit code 1

Here's my code:

\documentclass{report}

\usepackage{psvectorian}

\newcommand{\ornamentalBreak}{%
    \begin{center}
        \psvectorian[width=2in]{83} 
    \end{center}%
}

\begin{document}
    asdf asdfjkajs;df
    
    \ornamentalBreak
    
    asdfsdfaslfd;

\end{document}

My pst-vectorian package is v. 41 (rev 60488). I'm using TexLive on Windows and compiling with Xelatex. I noticed that Ghostscript is currently at 9.55, but I can't figure out how to get the version in Texlive to update to that.

ADD: tlgs.win32 now updated to rev 60648 so now I'm getting version 9.55 in Latex but still the same error.

3
  • Have yuo tried using lualatex instead? Xelatex fails for me too on linux, but lualatex compiles
    – daleif
    Oct 1, 2021 at 10:39
  • It does work for me in lualatex, thanks. I feel like there was a reason I was using Xelatex for something that I can't remember, though. I'll have to see how it affects the rest of my files.
    – Jon Arnold
    Oct 2, 2021 at 3:17
  • I think if starting out, jump straight to lualatex, it is easier to work with in certain ways
    – daleif
    Oct 2, 2021 at 4:34

1 Answer 1

0

After some help from Herbert Voss, adding -output-driver="xdvipdfmx -i dvipdfmx-unsafe.cfg -q -E" to my compilation xelatex command was a functional workaround.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .