1

I have made a Latex document containing a single image in the body and compiled it with pdflatex (Tex Live 2019) on Ubuntu 20.04.2 LTS. In the resulting PDF, I there is no image but the meaningless symbols ,ь, instead. Here is the document:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1,T2A]{fontenc}
\usepackage[english]{babel}
\usepackage{graphicx}

\begin{document}
\begin{figure}
  \includegraphics[width=0.7\linewidth]{passer.jpg}
  \caption{A sparrow}
\end{figure}
\end{document}

Although the image doesn't appear in the PDF, there are no errors and warnings in the pdflatex output. However, the figure appears when I don't include the babel package. Also, the figure appears in the output when I add the [h] argument, but the issue comes back if I include two figures (in this case, the first figure is present but the second one is not). I am working on a cyrillic document, so I need help in making figures appear correctly with babel package.

The compilation result

EDIT 1: This is the compilation log when babel package is included:

This is pdfTeX, Version 3.14159265-2.6-1.40.20 (TeX Live 2019/Debian) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./test1.tex
LaTeX2e <2020-02-02> patch level 2
L3 programming layer <2020-02-14>
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2019/12/20 v1.4l Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size10.clo))
(/usr/share/texlive/texmf-dist/tex/latex/base/inputenc.sty)
(/usr/share/texlive/texmf-dist/tex/latex/base/fontenc.sty
(/usr/share/texlive/texmf-dist/tex/latex/cyrillic/t2aenc.def
(/usr/share/texlive/texmf-dist/tex/latex/base/t2aenc.dfu))
(/usr/share/texlive/texmf-dist/tex/latex/cyrillic/t2acmr.fd))
(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.sty
(/usr/share/texlive/texmf-dist/tex/generic/babel/switch.def)
(/usr/share/texlive/texmf-dist/tex/generic/babel-english/english.ldf
(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.def
(/usr/share/texlive/texmf-dist/tex/generic/babel/txtbabel.def))))
(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphicx.sty
(/usr/share/texlive/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphics.sty
(/usr/share/texlive/texmf-dist/tex/latex/graphics/trig.sty)
(/usr/share/texlive/texmf-dist/tex/latex/graphics-cfg/graphics.cfg)
(/usr/share/texlive/texmf-dist/tex/latex/graphics-def/pdftex.def)))
(/usr/share/texlive/texmf-dist/tex/latex/l3backend/l3backend-pdfmode.def)
(./test1.aux)
(/usr/share/texlive/texmf-dist/tex/context/base/mkii/supp-pdf.mkii
[Loading MPS to PDF converter (version 2006.09.02).]
) (/usr/share/texlive/texmf-dist/tex/latex/epstopdf-pkg/epstopdf-base.sty
(/usr/share/texlive/texmf-dist/tex/latex/latexconfig/epstopdf-sys.cfg))
[1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}]
Overfull \vbox (10.0pt too high) has occurred while \output is active
(./test1.aux) )
(see the transcript file for additional information){/usr/share/texmf/fonts/enc
/dvips/cm-super/cm-super-t2a.enc}</usr/share/texmf/fonts/type1/public/cm-super/
sfrm1000.pfb>
Output written on test1.pdf (1 page, 7430 bytes).
Transcript written on test1.log.

And this is the compilation log without babel package:

This is pdfTeX, Version 3.14159265-2.6-1.40.20 (TeX Live 2019/Debian) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode
(./test1.tex
LaTeX2e <2020-02-02> patch level 2
L3 programming layer <2020-02-14>
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2019/12/20 v1.4l Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size10.clo))
(/usr/share/texlive/texmf-dist/tex/latex/base/inputenc.sty)
(/usr/share/texlive/texmf-dist/tex/latex/base/fontenc.sty
(/usr/share/texlive/texmf-dist/tex/latex/cyrillic/t2aenc.def
(/usr/share/texlive/texmf-dist/tex/latex/base/t2aenc.dfu))
(/usr/share/texlive/texmf-dist/tex/latex/cyrillic/t2acmr.fd))
(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphicx.sty
(/usr/share/texlive/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphics.sty
(/usr/share/texlive/texmf-dist/tex/latex/graphics/trig.sty)
(/usr/share/texlive/texmf-dist/tex/latex/graphics-cfg/graphics.cfg)
(/usr/share/texlive/texmf-dist/tex/latex/graphics-def/pdftex.def)))
(/usr/share/texlive/texmf-dist/tex/latex/l3backend/l3backend-pdfmode.def)
(./test1.aux)
(/usr/share/texlive/texmf-dist/tex/context/base/mkii/supp-pdf.mkii
[Loading MPS to PDF converter (version 2006.09.02).]
) (/usr/share/texlive/texmf-dist/tex/latex/epstopdf-pkg/epstopdf-base.sty
(/usr/share/texlive/texmf-dist/tex/latex/latexconfig/epstopdf-sys.cfg))
[1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map} <./passer.jpg>]
(./test1.aux) ){/usr/share/texmf/fonts/enc/dvips/cm-super/cm-super-t2a.enc}</us
r/share/texmf/fonts/type1/public/cm-super/sfrm1000.pfb>
Output written on test1.pdf (1 page, 72668 bytes).
Transcript written on test1.log.

EDIT 2: I have uploaded the logs and the image from the example to the Google drive. Here is the link: https://drive.google.com/drive/folders/180QeQwz6L9FyM2aQXDQyNS_-_NopiaJ7?usp=sharing

10
  • Welcome to TeX.SE!
    – Mensch
    Sep 29, 2021 at 15:30
  • Could you please provide the log of your compilation of this exact example? I have never seen babel affecting images before and since I do not have your example image, I'd like to see the log file, preferably with and without babel
    – daleif
    Sep 29, 2021 at 15:30
  • Sure, I have added the outputs of pdflatex in the question. Or did you mean the content of log files?
    – E. Anikin
    Sep 29, 2021 at 15:49
  • you should show the complete log file. And make the jpg available somehow. Sep 29, 2021 at 15:54
  • 1
    I can't reproduce your issue. Your log does shows an suspicious overful vbox, but no indication where it is from. But I'm on windows and my systems have different package versions than yours. Sep 29, 2021 at 17:16

1 Answer 1

1

The issue disappeared after I installed TexLive 2021 directly from tug.org. Before, I tried to purge and reinstall Texlive from Ubuntu repository, but that didn't help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .