0

I installed LYX by the official instructions. When I view[ctrl+R] a document which includes only English text - a new PDF file open properly, but if the document includes Hebrew letters I get an error (attached as picture). I had tried to download 'culmus.sty' file and copy to some directories, but it didn't help.
~ The files directories which were mentioned:

  • AppData\Local\Programs\MiKTeX\tex\latex\culmus
  • AppData\Local\Programs\MiKTeX\tex\latex\tools
  • AppData\Roaming\MiKTeX\2.9\tex\latex\culmus
  • C:\Users~myUserName~\culmus\tex\latex\culmus

error output

5
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Oct 5, 2021 at 9:37
  • I would advise you to use lualatex instead of pdflatex for hebrew. Installing and using culmus is quite a pain. Oct 5, 2021 at 10:58
  • Thanks @UlrikeFischer , how I do so?
    – BeNavon
    Oct 5, 2021 at 11:24
  • You can find various lualatex examples here on the site, but I'm not a lyx user and can' t tell you how to use them there. Oct 5, 2021 at 11:41
  • Apparently, multilingual support in LyX is a bit out of date and it doesn’t take into account the latest developments in babel for xetex and luatex. But may be I’m wrong (in fact, I’d like to be wrong!). Oct 5, 2021 at 14:21

2 Answers 2

0

OK guys, if you write Hebrew documents - you should follow after this guide :)

0

I think I’ve managed to configure LyX to use babel with lualatex. The key point is to bypass the way LyX configures languages and fonts. Here is a set of screenshots (in the 2nd screen the language should read ‘Hebrew’, of course, not ‘Hebreo’).

With the first setting (Font) we avoid loading luainputenc, which is strongly discouraged, but added by default by LyX with luatex. Note no font is actually selected, but this is the only way I’ve found to get rid of that package.

enter image description here

The next setting tells LyX not to use any package for languages.

enter image description here

And now, the real thing by hand.

enter image description here

Edit. If the previous code doesn’t work for you, try with:

\usepackage[bidi=basic]{babel}
\babelprovide[import, main]{hebrew}
\babelfont{rm}{FreeSerif}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.