0

When I open any .tex file from a mounted partition (exFAT file system) in TeXShop, edit it and then save, I get "The document [filename] could not be saved." Afterward, at the top of the window, it says "Not Saved" with a hint "The document could not be autosaved." Using the menu or the keyboard shortcut makes no difference.

Saving such files worked before. Files on the main system partition still save without problems.

I am on the current latest macOS Catalina and latest TeXShop version.

P.S.: The volume is mounted via macFUSE and VeraCrypt, both the latest versions. Any hints would be appreciated, as this makes TeXShop unusable for me.

3
  • Try manually saving the file in a different directory. If you are able to do that then it seems it wodul be a problem with having write access to the directory. Also, can you open a .txt file in Edit and save that in the same directory which has the issue? If so, then it is not a TeXShop issue. Commented Oct 14, 2021 at 18:15
  • Thanks, hints are welcome. I had checked editing the file (via vi), worked. I have been using this setup for years, plain access rights should not be the problem. After a reboot, it now works again. I had had this problem occasionally before, but it usually went away again, and did not last as long as this time. I will update the question once it happens again.
    – mrupp
    Commented Oct 15, 2021 at 19:55
  • 1
    Glad your issue was resolved. On MacOS, I have also experienced intermittent issues with being denied read permission to files that I created on my locak disk (via the current account) but have not been ablle to figure out how to reproduce them. Commented Oct 16, 2021 at 6:37

0

You must log in to answer this question.

Browse other questions tagged .