1

I recently downloaded the new Sublime Text 4 version on a Mac and manually set up LaTeXTools, MacTeX, and Skim using the documentation provided here: https://latextools.readthedocs.io/en/v3.13.0/README/

I understand that Sublime Text 4 isn't officially supported by LaTeXTools yet, but I thought I'd give it a go. The LaTeX system works normally. Both pdfLateX and LuaLateX/XeLaTeX generate PDFs, the traditional and basic builders both work fine, and both bibTeX and bibLaTeX (with a Biber backend) function normally. The only thing that doesn't work is Skim. It won't open itself when a new PDF is built while it's closed, and it won't update when a new PDF is built while it's open. I made sure to edit the sync functionality as instructed in the README (see above link) and I've double-checked that Skim opens a PDF when I invoke the 'open -a Skim.app' command (as found in Preferences -> Package Settings -> LateXTools -> Settings - Advanced, "open_image_command" ) in a terminal.

I'm not really a LaTeX or Sublime Text wizard, and I only have a cursory knowledge of how a package like LaTeXTools works, so I don't have any idea where to go from here. Any help would be appreciated.

4
  • Welcome to TeX.SE! I'm not sure if that question is on topic here ...
    – Mensch
    Commented Oct 14, 2021 at 18:47
  • Oops. I can move it if I need to. Which site would be better?
    – Jake
    Commented Oct 14, 2021 at 18:51
  • Well, I'm not sure, let us see if someone here can answer it. I do not use Sublime ...
    – Mensch
    Commented Oct 14, 2021 at 19:01
  • I do not have the reputation to add comments or vote, but I would like to say that updating skim to 1.6.8 solved this issue for me as well.
    – J.Kennedy
    Commented Feb 10, 2022 at 18:17

1 Answer 1

0

I had the same problem after upgrading to Monterey (12.1). I tried a solution proposed here:

https://github.com/SublimeText/LaTeXTools/issues/1553#issuecomment-999511000

but it did not help. I used ST4 (build 4126) and Skim 1.6.7. Today, Skim asked me to update to 1.6.8. I did and now the problem is gone!

I had used 1.6.8 before and it did not work. So, the sequence of events that lead to this result is: (1) get rid of Skim; (2) download and install Skim 1.6.7; (3) ask Skim to check for an update and install 1.6.8.

I have no idea whatsoever to explain this outcome.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jan 13, 2022 at 16:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .