4

The new texstudio (4.0.1) added three new buttons to the top right of the tool bar. When pressing them, the insert a \alert{}, \comment{}{} and a \add{} into the texfile. However, compiling them results in an Undefined control sequence. \comment error.

What are these buttons supposed to do? And am I missing a package?

Edit: As suggested in the comments, I have added a code sample here:

\documentclass{article}
\usepackage{amsmath}
\pagestyle{empty}
\begin{document}
    some crazy text what so ever \\
    $ a = b + c $
    
    \comment{and after the formula}{gg zz uu}
    \alert{some text}

\end{document}
9
  • 2
    I think some of these buttons should only be available when certain packages or classes are used. Maybe something went wrong there. At least alert seems to come from beamer.
    – daleif
    Oct 18, 2021 at 14:25
  • @daleif Oh, ok that makes sense. I first thought that these are linked to the pdf mark-up things, where you can highlight text and add comments.
    – Isotope
    Oct 18, 2021 at 14:44
  • 1
    You should load the easyReview package for using these commands. Oct 18, 2021 at 14:48
  • 7
    What a bizarre addition without mention of anything to support it. Seems like one of the developers just "liked it." Github.
    – Werner
    Oct 18, 2021 at 16:09
  • 2
    @Isotope: Yes. Or if the toolbar magically appeared once you added easyReview to your preamble. But just to be there, useable and cause failure without mention of a remedy seems to encourage problems. My suggestion would be to remove the Review toolbar because of this ad-hoc-ness.
    – Werner
    Oct 19, 2021 at 15:41

1 Answer 1

8
\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage{easyReview} % for \comment, \alert, etc.
\usepackage{soulutf8} % for accented letters
\begin{document}
    \comment{and after the formula}{gg zz uu}
    \alert{some text őőőő}
\end{document}
3
  • interested in easyReview, I tried to do a test but it crashes with the xcolor library. is there a solution?
    – Antonio
    Feb 16 at 17:59
  • @Antonio: The xcolor package is loaded by easyReview, no need to reload. Feb 17 at 10:49
  • thank you for the clarification. keeps giving me the same error over and over. i am using the book class
    – Antonio
    Mar 14 at 5:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.