0

I was previously using Overleaf but since I don't want to pay to get more compiling time I decided to start using TEXMaker with MIKTex on my desktop instead.

I had a nice-looking title page, with everything fitting onto a single page (which I will show below). But now, it is getting pushed to the second page. Can I get some help correcting this issue?

Here is the part of my LaTex code I've moved over from the .tex file used in Overleaf. It's been several months since I put together the original preamble so maybe I just haven't included the necessary packages that fixed this problem. I think I may also be using the vspace tool wrong, or something is not cross-compatible between Overleaf and TEXMaker.

Thanks in advance.

\documentclass[11pt,twoside,openany]{book}
\usepackage[utf8]{inputenc}

% header/footer


% page numbering


% double spacing
\usepackage{setspace}

\begin{document}
\doublespacing
% \pagenumbering{gobble}

\begin{titlepage}
    \begin{center}
        \normalsize
        \begin{doublespace}
            \vspace*{0.5in}
            The Super Awesome University\\
            The Graduate School\\
            
            \vspace{1in}
            
            \textbf{\MakeUppercase{Thesis Title}}
            
            \vspace{1in}
            
            A Dissertation in\\
            The Most Important Degree\\
            by\\
            
            John Wick
            
            \vspace{0.75in}
            
            \textcopyright 2021 John Wick
            
            \vspace{0.75in}
        \end{doublespace} 
        
        \begin{singlespace}
            Submitted in Partial Fulfillment\\ 
            of the Requirements\\
            for the Degree of\\
        
            \vspace{0.4in}
            
            Doctor of Philosophy
            
            \vspace{0.4in}
            
            Dec 2021
            
            \vfill
        \end{singlespace} 
    \end{center}
\end{titlepage}

\end{document}
4
  • you are just using standard book class features there I'd be surprised if that gave a different output in overleaf. Since you are adding explicit spaces everywhere it is trivial to adjust it to "look right" after you add the real text, eg changing the first vspace*{.5in} to -.5in or reduce the 1in after the title or .... Commented Oct 22, 2021 at 15:32
  • Putting \\ in front of a blank line may give inconsistent results, depending on \parskip. If there are any spaces which are not specified by the requirement, you might consider using glue (\vfill or something like \vspace{0.75in plus 1fil}). And when are they going to drop the "double space" requirement for any thesis not written on a typewriter? Commented Oct 22, 2021 at 19:04
  • @JohnKormylo, I will try that and get back.
    – WnGatRC456
    Commented Oct 22, 2021 at 20:08
  • I actually got Overleaf working without needing more compiling time because of unrelated issues, so I'll be sticking with that for now.
    – WnGatRC456
    Commented Oct 23, 2021 at 1:55

2 Answers 2

0

Does this suit you

enter image description here

\documentclass[11pt,twoside,openany]{book}
\usepackage[utf8]{inputenc}

% header/footer


% page numbering


% double spacing
\usepackage{setspace}

\begin{document}
% \doublespacing
% \pagenumbering{gobble}

\begin{titlepage}
    \begin{center}
        \normalsize
        % \begin{doublespace}
            \vspace*{0.5in}
            The Super Awesome University\\
            The Graduate School\\
            
            \vspace{1in}
            
            \textbf{\MakeUppercase{Thesis Title}}
            
            \vspace{1in}
            
            A Dissertation in\\
            The Most Important Degree\\
            by\\
            
            John Wick
            
            \vspace{0.75in}
            
            \textcopyright 2021 John Wick
            
            \vspace{0.75in}
        % \end{doublespace} 
        % 
        % \begin{singlespace}
            Submitted in Partial Fulfillment\\ 
            of the Requirements\\
            for the Degree of\\
        
            \vspace{0.4in}
            
            Doctor of Philosophy
            
            \vspace{0.4in}
            
            Dec 2021
            
            \vfill
        % \end{singlespace} 
    \end{center}
\end{titlepage}

\end{document}
2
  • Is this on a different page size? I want to use the standard letter size (8.5 x 11). Otherwise it looks good. I also want the majority of the document to be double spaced, so if you comment out \doublespace right after the document begins then I won't get my desired result ultimately.
    – WnGatRC456
    Commented Oct 22, 2021 at 18:21
  • @WnGatRC456 So why not put \doublespacing after the title page? Do you specify letterpaper in your class options?
    – cfr
    Commented Nov 12, 2023 at 4:11
0

Inch is a large & fixed unit to be used with \vspace here. Try using elastic lengths. Try \vspace*{3\bigskipamount} at the top instead of \vspace*{0.5in} and \vspace{2\medskipamount} instead of \vspace{0.4in}.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .