0

I am using the fncychap package for my book. The gap between the title and the content of a chapter is too large. I want to reduce it, so I read those two solutions :

The solutions suggested in those topics didn't worked (no errors were being raised but I didn't affect the document)

How can I reduce the space between the title and the content with fncychap ?

EDIT : Here is a MWE :

\documentclass[10pt,b5paper,twoside]{book}
\usepackage[utf8]{inputenc}
\usepackage[french]{babel}
% Layout :
\usepackage[twoside,bindingoffset=6mm,verbose,marginratio={4:6,5:7},
textwidth=117.3mm,height=179.6mm]{geometry} 
% ===========================================
% Polices :
\usepackage{lmodern}
% ###########################################
% HEADER
% ###########################################
\usepackage[Glenn]{fncychap}
\ChNameVar{\bfseries\Large\sf}
\ChNumVar{\Huge}
\ChTitleVar{\bfseries\Large}
\ChRuleWidth{1pt}
\ChNameUpperCase
\ChTitleUpperCase
\usepackage{lipsum}
%============================================
\begin{document}
\chapter{A chapter}
\lipsum[1]
\end{document}

Thank you in advance for any advice.

4
  • 1
    I thought the whole purpose of packages like fancychap was to avoid modifying \@makechapterhead yourself. Commented Oct 24, 2021 at 15:00
  • I don't know, the solution I implemented here was one of those I found here on SX. But It doesn't work. I edited my post and deleted the implementation
    – Elyo
    Commented Oct 24, 2021 at 15:03
  • Okay, in the manual there are commands like \DOCH, \DOTI and \DOTIS which contain \vskip 40pt. These are the source of the gaps. Modify them, not \@makechapterhead. Commented Oct 24, 2021 at 15:38
  • @JohnKormylo Thank you, since I don't know how to properly modify these commands, I supply put after \chapter{a chapter} a \vskip-60pt to do the job.
    – Elyo
    Commented Oct 24, 2021 at 16:22

1 Answer 1

2

This uses etoolbox to modify the existing code from Glen. Other styles may use different code. For completeness, I also show how to reduce the space above the chapter.

You should remove the [showframe] option from geometry when eventually.

\documentclass[10pt,b5paper,twoside]{book}
\usepackage[utf8]{inputenc}
\usepackage[french]{babel}
% Layout :
\usepackage[twoside,bindingoffset=6mm,verbose,marginratio={4:6,5:7},
textwidth=117.3mm,height=179.6mm, showframe]{geometry} 
% ===========================================
% Polices :
\usepackage{lmodern}
% ###########################################
% HEADER
% ###########################################
\usepackage[Glenn]{fncychap}
\ChNameVar{\bfseries\Large\sf}
\ChNumVar{\Huge}
\ChTitleVar{\bfseries\Large}
\ChRuleWidth{1pt}
\ChNameUpperCase
\ChTitleUpperCase

\usepackage{etoolbox}
\makeatletter
\patchcmd{\@makechapterhead}{\vspace*{50\p@}}{\vspace*{20\p@}}{}{FAILED 1}% change space above chapter
\patchcmd{\@makeschapterhead}{\vspace*{50\p@}}{\vspace*{20\p@}}{}{FAILED 2}% change space above chapter*
\patchcmd{\DOTI}{\vskip 80\p@}{\vskip 20\p@}{}{FAILED 3}% change space below chapter
\patchcmd{\DOTIS}{\vskip 40\p@}{\vskip 20\p@}{}{FAILED 4}% change space below chapter*
\makeatother
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\usepackage{lipsum}
%============================================
\begin{document}
\chapter{A chapter}
\lipsum[1]
\end{document}
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .