For instance, I want to include a figure: ~/figures/figure.pdf. On my Linux box, this is /home/me/figures/figure.pdf, but on OS X it is /Users/me/figures/figure.pdf. I'd like it if there is an environment variable like $HOME so that the latex file can compile on both machines \includegraphics{$HOME/figures/figure.pdf}. (Of course it wouldn't use the $ sign).

I just found this post, but Is write18 the most native way? And, in the given example, the assignment wouldn't actually define the variable in LaTex. I tried

\immediate\write18{echo "\newcommand{\HOME}{$HOME}" > var.tex}

But gives me this error:

! Argument of \@gobble has an extra }.

So now I am at a loss.


@egreg has already answered your question so I thought I'd not answer it. That is suggest not relying on environment variables for this. If the latex file just goes \includegraphics{figures/figure.pdf}

then if $HOME/figures// is in TEXINPUTS environment variable or texmf.cnf configuration setting then the file will be found without LaTeX explicitly needing to access the machine-specific information. This keeps machine specific information and directory structure in the kpathsearch system which is optimised to deal with that rather than the macro layer which tries as far as possible to avoid such issues.

Also for the specific case of home directory you can (on web2c systems on at least linux and windows/cygwin, but I assume the others too) use \string~/figures/figure.pdf as kpathsea understands ~ as the home directory (but you have to pass it a literal ~ not the normal active definition for a non-breakable space, hence the \string.


If you have a recent TeX Live (2010 or later) or MiKTeX (v. 2.9), then the following works (and does not need the -shell-escape command line option):

  \CatchFileEdef{\temp}{"|kpsewhich --var-value #2"}{}%


If you only say \getenv{VAR} then the value of the variable is printed instead of being stored in a control sequence.

Not only HOME can be used, but any environment variable and also the "pseudovariables" defined in the TeX kpathsea system such as TEXMF or TEXINPUTS.

Note that this works only with pdflatex. With other engines or older distributions, shell escape is needed. Of course LuaTeX has its methods for interacting with the system.

A version that works with all recent engines is



    \immediate\write18{kpsewhich --var-value #2 > \jobname.tmp}%
        kpse.var_value("\luatexluaescapestring{#2}") or "" ) }}%
      \CatchFileEdef{\temp}{"|kpsewhich --var-value #2"}{\endlinechar=-1}%


In the case of xetex an auxiliary file \jobname.tmp is written and -shell-escape is necessary.

Note: the LuaTeX method has been suggested by Patrick Gundlach. If the variable is unset or not known to kpathsea, the empty string will result.

  • I'd like to use \getenv[VAR]{envvar} in a situation where envvar may not have been defined. I've been trying unsuccessfully to condition on the output of \getenv in this case. Is it possible to modify the command so that it returns something like UNDEFINED if there environment variable hasn't been defined? – Leo Simon Oct 24 '16 at 17:25
  • @LeoSimon Add before the \if\relax lines, the line \ifx\temp\empty\def\temp{UNDEFINED}\fi Or do a test for emptyness when the macro is used. – egreg Oct 24 '16 at 17:51
  • Thanks for the suggestion, but I can't get it to work. Here's an MWE, although I don't know how to put code into a comment \documentclass{article} \usepackage{catchfile} \newcommand{\getenv}[2][]{% \CatchFileEdef{\temp}{"|kpsewhich --var-value #2"}{}% \ifx\temp\empty\def\temp{UNDEFINED}\fi \if\relax\detokenize{#1}\relax\temp\else\let#1\temp\fi} \begin{document} The getenv command should return UNDEFINED but returns \getenv{NOT_DEFINED} \end{document} In this example \getenv{NOT_DEFINED} returns empty – Leo Simon Dec 4 '16 at 21:07
  • @LeoSimon If you have a followup question, please ask one – egreg Dec 5 '16 at 0:04
  • This used to work pretty well, but a recent change to kpsewhich broke it unfortunately: When called with --var-value, it doesn't print the environment variable's content verbatim, but does brace expansion on the value. Unfortunately, even that is buggy, so that it expands a comma even outside of curly braces: $ CHAMAELEOGEOMETRY='XX=yy,z=4' kpsewhich --var-value CHAMAELEOGEOMETRY XX=yy:z=4 I used to suppl comma-separated values here (for setting a page geometry from outside), but since the comma gets converted to a colon, that doesn't any longer work. A kpsewhich bug? – Jan-Benedict Glaw Dec 17 '18 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.