6

I planning to write a long report (~300 pages) in latex. My report will contain a lot of Bangla text along with English text. I found several ways to write Bangla in latex, but I failed to choose the best way.

Another important thing is that when I use Bangla setting as main font, it changes the font face of default English font of latex. I used the command:

\setmainfont{[Kalpurush]} 

I showed this differences in the figures. In figure 1, before setting the Bangla as main font. In figure 2, after setting the Bangla as main font. I don't want this change, is it possible to keep the same font face? It may be visual change, how to avoid this?

enter image description here

Figure 1: Before setting Bangla as main font

enter image description here

Figure 2: After setting Bangla as main font

So, I want to know the best way of using Bangla in latex without changing the default English font face. How can I do that?

I want both English and Bangla fonts. Latin Computer Modern as English font and Kalpurush as Bangla font.

2
  • Incidentally, what is your preferred main text font? Latin Modern? Something else?
    – Mico
    Commented Oct 28, 2021 at 16:46
  • I want both English and Bangla fonts. Latin Computer Modern as English font and Kalpurush as Bangla font.
    – mmr
    Commented Oct 28, 2021 at 16:47

1 Answer 1

10

Assuming lualatex and english as the main language.

\documentclass{article}

\usepackage[english]{babel}

\babelprovide[import, onchar = fonts ids]{bengali}

\babelfont[bengali]{rm}[Renderer=Harfbuzz]{FreeSerif}

\begin{document}

Let’s write a short English text, and then a Bangla one (from the
Wikipedia): বাংলা ভাষা বিকাশের ইতিহাস ১৩০০ বছর পুরনো। চর্যাপদ এ ভাষার
আদি নিদর্শন.

\end{document}

enter image description here See also the page on Bangla in the babel site.

2
  • If I want to use Kalpurush font for Bangla type setting?
    – mmr
    Commented Oct 28, 2021 at 16:52
  • 3
    @Masudur - Then, just replace FreeSerif with Kalpurush.
    – Mico
    Commented Oct 28, 2021 at 16:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .