I've been using lyx for many years, mostly on Linux, and on MacOS for a a few years.

On upgrading macOS Big Sur to macOS Monterey 12.0.1 suddenly printing stopped working.


I'm using the latest Lyx 2.3.6, MacTex 2021, latest firmware and drivers for the Xerox 6510DN printer. The reason I mention the printer is that it is a true postscript printer and has worked without issue on Linux, Windows, Mac, BSD because it doesn't really need a driver.


The postscript errors are of the usual form "ERROR: undefined, OFFENDING COMMAND: ". See image attached for 3 attempted prints. The actual offending command varies.

Attempts to Diagnose / Fix

I've tried to use MacOS Preview to "print to postscript". I reasoned that this is what happens when the document is sent to the printer.

It turns out MacOS Preview itself fails to load these postscript files, the ones it generated itself.

I tried to open the postscript files with TexShop (not Preview) which generates a new PDF. The first page works, but the remainder of the document is not produced, and the second page has a postscript error, eg "ERROR: ioerror, OFFENDING COMMAND: eexec"

I then tried to upgrade the MacTEX packages which I usually don't do because I like to stick with the "frozen and tested" MacTEX distribution. This didn't help.

I then manually installed the Ghostscript 9.55 package as the installed one was older. This didn't help either.

Finally, I took the Lyx generated PDF and from a command prompt used pdf2ps and the ps2pdf which generates a much smaller PDF (2.1MB pdf1.4 compared to 3.9MB pdf1.5). I haven't yet test physical printing with these, but the preview of Preview printing postscript to a file seems ok. The PDF's hyperlinks no longer work, but I can live with this.

One final data point - I went back to my backups to get the Lyx generated PDFs before the MacOS upgrade to Monterey, and under Monterey, they too fail to point.

Update: I can confirm that Adobe Reader on MacOS prints the PDF, as was suggested by a comment elsewhere. Here is the lyx-generated PDF I am mostly testing (PDF).


Any suggestions on what is wrong, and how to fix it? I suspect the cause is Monterey as nothing else changed.

enter image description here

1 Answer 1


MacOS prints by first converting the print job to a pdf file. Then it looks at the printer. If the user has a postscript printer, macOS converts the pdf file to a postscript file and sends that to the printer. The print dialog also allows users to write this postscript file to disk. A bug in Monterey causes macOS to write defective postscript files when the pdf contains certain TeX fonts, including Computer Modern. This has been reported to Apple. Printing to ink jet printers works, and adding the source line \usepackage{lmodern} to convert to Latin Modern fonts often fixes the problem for users.

  • 1
    Thanks richard, I too spent about 3-4 hours yesterday trying to get through to someone at Apple who understood the problem and was going to raise it with engineering. I'm currently using pdf2ps then ps2pdf (both Ghostscript) to create PDFs that print. This seems to work but I don't know why. Such a shame that a large company can mess up this basic capability.
    – Penelope
    Nov 2, 2021 at 22:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .