0

I am writing a document with:

\documentclass{amsart} 
\usepackage[style=philosophy-modern, backend=biber]{biblatex}

Any two references of same author.

I cannot determine why there is a problem, with another package or some code. The first date after a new author block is not aligned with subsequent dates.

Any idea how to fix this, even by hand, once biber has done its work?

A MWE is included below:

\documentclass{article}
\usepackage[style=philosophy-modern, backend=biber, ]{biblatex}
\begin{filecontents}[overwrite]{\jobname.bib}
 @book{key,
    author = {Max Muster},
    maintitle = {Der Werktitel},
    title = {Titel des zweiten Bandes},
    volume = {2},
    location = {Ort},
    year = {2002},
    keywords = {muster, etwas},
}
@book{keya,
    author = {Max Muster},
    maintitle = {Der Werktitel},
    title = {Titel des Dritten Bandes},
    volume = {3},
    location = {Ort},
    year = {2002},
}
@book{other,
    author = {Michael Karomann},
    maintitle = {Etwas},
    title = {Nichts},
    volume = {3},
    location = {Ort},
    year = {2002},
    keywords = {test, etwas},
}
@book{other2,
    author = {Michael Karomann},
    maintitle = {Etwas},
    title = {Nichts},
    volume = {3},
    location = {Ort},
    year = {2008},
    keywords = {test, etwas},
}
\end{filecontents}

\addbibresource{\jobname.bib}


\begin{document}
    \nocite{*}
    \printbibliography
\end{document}
5
  • 2
    looks ok to me, I get this result i.sstatic.net/Efpul.png with a current texlive. Nov 8, 2021 at 20:11
  • 1
    Surely the MWE should have \documentclass{amsart} and not \documentclass{article}?
    – moewe
    Nov 8, 2021 at 20:16
  • The image given by Ulrike shows the problem, and this is the same with amsart which I use!
    – Fred_O
    Nov 8, 2021 at 21:41
  • Moreover, @moewe when passing from article to amsart the problem is slightly different, since it occurs event for the second author with amsart.
    – Fred_O
    Nov 8, 2021 at 21:46
  • I can see a weird effect with amsart. But when I use article I get the output posted by Ulrike, which looks fine to me. Can you please explain exactly what is wrong with that output?
    – moewe
    Nov 9, 2021 at 6:20

1 Answer 1

1

There is an odd effect with amsart where the first entry under each name heading would receive additional indentation. This is caused by the \listparindent setting of that class and can be countered by setting that length to zero in the bibliography environment definition.

\documentclass{amsart}
\usepackage[backend=biber, style=philosophy-modern,]{biblatex}

\defbibenvironment{bibliography}
  {\list
     {}
     {\setlength{\listparindent}{0pt}%
      \setlength{\leftmargin}{\bibhang}%
      \setlength{\itemindent}{-\leftmargin}%
      \setlength{\itemsep}{\bibitemsep}%
      \setlength{\parsep}{\bibparsep}}}
  {\endlist}
  {\item}

\addbibresource{biblatex-examples.bib}

\begin{document}
  \nocite{knuth:ct:a,knuth:ct:b,knuth:ct:c,
    sigfridsson,worman}
  \printbibliography
\end{document}

Uniformly indented entries

If there are several entries by the same group of authors from the same year, biblatex adds letters to those years. This causes the relevant citation labels to become longer than usual. Because the style aligns all citation labels to the right (this achieves a uniform distance to the beginning of the entry) that means that the years don't line up on the left. If you prefer left-aligned years, you may want to try the following redefinition. (You can tweak the value 1.6em.)

\documentclass{amsart}
\usepackage[backend=biber, style=philosophy-modern,]{biblatex}

\defbibenvironment{bibliography}
  {\list
     {}
     {\setlength{\listparindent}{0pt}%
      \setlength{\leftmargin}{\bibhang}%
      \setlength{\itemindent}{-\leftmargin}%
      \setlength{\itemsep}{\bibitemsep}%
      \setlength{\parsep}{\bibparsep}}}
  {\endlist}
  {\item}

\renewcommand*{\postsepyear}[1]{%
  \printtext{%
    \makebox[\bibhang][l]{%
    \hspace{1.6em}#1}}\nopunct}

\addbibresource{biblatex-examples.bib}

\begin{document}
  \nocite{knuth:ct:a,knuth:ct:b,knuth:ct:c,
    sigfridsson,worman}
  \printbibliography
\end{document}

left-aligned years

2
  • Thanks for this solution, it works fine!
    – Fred_O
    Nov 9, 2021 at 10:09
  • And the problem was the same with article: the firs titles were not aligned with the second enty!
    – Fred_O
    Nov 9, 2021 at 10:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .