1

I'm got this template that gives me errors like this one:

LaTeX Error: File `' not found.
 
‪main.tex, 74‬
The compiler cannot find the file you want to include. Make sure that you have uploaded the file and specified the file location correctly.

For every \chapter and for my Table of Contents \tableofcontents. I think the template wants to insert a picture at every chapter, however I don't want any pictures here. I think I found the part where this is implemented, but since I'm fairly new to LaTeX I don't know how to remove the Image insertion or how to avoid the Errors.

How do I get rid of the Errors without using Pictures?

Link to structure.tex: https://github.com/PIX3LFLUX/HSK-Latex-Skript-Template/blob/main/structure.tex

0

The template mentions a switch called usechapterimage which can be set to true or false. If it is set to true then you must also use the command \chapterimage to provide the filename of the chapter image. If the switch is true but the filename is not provided then the error that is mentioned in the question occurs.

The following code (copied from 00_main.tex) switches the chapter image off and comments the filename setting:

\usechapterimagefalse % If you don't want to include a chapter image, use this to toggle images off - it can be enabled later with \usechapterimagetrue

%\chapterimage{Pictures/csm_HKA_FK-EIT_2017-9363_a9e6e1d039.jpg} % Table of contents heading image

\pagestyle{empty} % Disable headers and footers for the following pages

\tableofcontents % Print the table of contents itself

\cleardoublepage % Forces the first chapter to start on an odd page so it's on the right side of the book

\pagestyle{fancy} % Enable headers and footers again


%----------------------------------------------------------------------------------------
%  Teil 1
\part{TEIL 1}
%----------------------------------------------------------------------------------------

\input{01_einleitung.tex}

Result:

enter image description here

Note that you didn't provide the code of your own document in the question, so it is difficult to say where exactly you should put the relevant code (i.e., the first line, consisting of \usechapterimagefalse). However, it should be somewhere before the first time you use \chapter but after you load structure.tex (because there the switch is turned to true).

1
  • Thank you! That fixed it Nov 9 '21 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.