1

I'm using a template I got off Keith Conrad's website (https://kconrad.math.uconn.edu/math2784f14/papertemplate.tex.html) for a class and I'd like to make the equation numeration appear on the right side. However, when I remove [leqno] from the command

\usepackage[leqno]{amsmath}

nothing happens, and when I change it to reqno the file doesn't compile, because of some "option clash" (when I change the package from amsmath to mathtools the error is not thrown, however the numbering isn't affected either). What do I do?

1 Answer 1

3

It is not advisable to link to templates or documents at places other than, for example, CTAN. But I understand that it is not feasable to paste the whole template here. So, here it goes:

The \documentclass used by the template is amsart which defaults to its option leqno. In order to avoid the option clash, you need to load the \documentclass with the option reqno as well.

So, you need to do two things:

  1. add the option reqno to the options of the amsart class

    \documentclass[12pt,letterpaper,reqno]{amsart}
    
  2. and change the option leqno to reqno for the package amsmath.

    \usepackage[reqno]{amsmath}
    

This should solve you problem and switch the equation numbers to the right.

2
  • Thanks, it worked! And what were to happen if I were to change amsmath to mathtools? I heard the latter is basically an improved version of the former, so it shouldn't break anything, right? Nov 18, 2021 at 11:15
  • You can try, but only because it is said to be an "improved version" does not necessarily mean that it won't break anything. It could work, though, since it internally loads amsmath anyways. Nov 18, 2021 at 11:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .