I am trying to run MiKTeX in a docker container, but I'm having problems with few fonts. I've seen multiple mentions that I need to do updmap but there is no such command available. mpm --update-db exits silently but does not help with the issue.

Here's my Dockerfile, which is slightly modified version of official MiKTeX dockerfile from here :

FROM ubuntu:focal

RUN apt-get update && apt-get install -y \
    python3 python3-pip

RUN apt-get install -y \
        apt-transport-https \
        ca-certificates \
        dirmngr \
        ghostscript \
        gnupg \
        gosu \
        make \

RUN apt-get clean

RUN echo 'Acquire::https::ctan.gust.org.pl::Verify-Peer "false";' > /etc/apt/apt.conf.d/99influxdata-cert

RUN apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys D6BC243565B2087BC3F897C9277A7293F59E4889

RUN echo "deb http://miktex.org/download/ubuntu focal universe" | tee /etc/apt/sources.list.d/miktex.list

RUN apt-get update -y \
    &&  DEBIAN_FRONTEND='noninteractive' apt-get install -y --no-install-recommends \

RUN    miktexsetup finish \
    && initexmf --admin --set-config-value=[MPM]AutoInstall=1 \
    && mpm --admin --update-db \
    && mpm --admin \
           --install amsfonts \
           --install biber-linux-x86_64 \
    && initexmf --admin --update-fndb

ENV PATH="${PATH}:/root/bin"

RUN pip install aiofiles pyside6

COPY . /app

When I try compiling my .tex file to .pdf it crashes with following error:

!pdfTeX error: pdflatex (file t1-zi4b-0): Font t1-zi4b-0 at 480 not found
 ==> Fatal error occurred, no output PDF file produced!
pdflatex: major issue: So far, no MiKTeX administrator has checked for updates.

Trying out updmap as suggested here:

root@ee9497470950:/app# updmap --admin
bash: updmap: command not found
  • Welcome to TeX.SE!
    – Mensch
    Nov 20, 2021 at 10:02
  • 1
    MiKTeX console , in the Tasks menu, has a Refresh font map files item.
    – Bernard
    Nov 20, 2021 at 10:47
  • @Bernard not really an option for a Docker container, especially since I want the image to be automated.
    – matszwecja
    Nov 20, 2021 at 11:08

1 Answer 1


Have you tried this solution (Inconsolata missing after MiKTeX update)?

TL;DR: Use \usepackage{zi4}

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Willoughby
    Nov 21, 2021 at 16:22
  • Thank you @Willoughby! I'll try to keep this line while posting here :) Nov 22, 2021 at 23:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .